Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Reply
 
Thread Tools Search this Thread
Old Apr 22, 2010, 5:43 PM   #21
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Well, at least I'm not suffering alone I guess...

I would definitely buy this lens again, but hope I don't have to.
Kiki FL is offline   Reply With Quote
Old Apr 24, 2010, 8:45 AM   #22
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Update: Got the lens back on Friday morning, which was a 3-day turn around and quite impressive. The packing slip said "Replaced Frame 3ZS", which is what the website had said and not very informative.

I called Olympus trying to determine exactly what the repair entailed and whether it was a common part failure or due to operator error, as I don't wish to repeat this process - especially the $300 part.

You would have thought I was trying to steal state secrets! Talked to 3 people in Tech Support/Customer Service who each told me that they had no way to interpret the code and that the people who could interpret the code were not allowed to answer the phone. I explained my concerns to no avail.

I have to say that I am immensely unimpressed with the way that Olympus treats its customers. When I spend $300 I'd like to know what it was for. Doesn't that seem reasonable? I thought it was. This has left a very, very bad taste in my mouth for this company. Great product; lousy bedside manner...

I never thought I would consider Canikon, but I might be doing that...

Thoughts?
Kiki FL is offline   Reply With Quote
Old Apr 24, 2010, 5:06 PM   #23
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,483
Default

Quote:
Originally Posted by Kiki FL View Post

I have to say that I am immensely unimpressed with the way that Olympus treats its customers. When I spend $300 I'd like to know what it was for. Doesn't that seem reasonable? I thought it was. This has left a very, very bad taste in my mouth for this company. Great product; lousy bedside manner...

I never thought I would consider Canikon, but I might be doing that...

Thoughts?
Call the equivalent telephone numbers for Canon, Nikon, Pentax or any other OEM maker and you're likely to get the same runaround. The people all these guys have answering the phones are simply not that knowledgeable. I was curious myself about the hardware replaced in mine, but having called before I just spared myself the frustration.

If you haven't done it yet, you're in for another treat if you ever apply for a mail-in rebate....
Greg Chappell is offline   Reply With Quote
Old Apr 24, 2010, 6:04 PM   #24
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Oddly enough, I've never had any trouble with Olympus rebates. That's why I was surprised with the cavalier response from the "tech support" crowd.

I asked a couple of friends that shoot Canon and Nikon. They seem satisfied with the treatment they are getting. Of course, that's hardly an inclusive survey, but it does give me pause...

Last edited by Kiki FL; Apr 24, 2010 at 6:47 PM.
Kiki FL is offline   Reply With Quote
Old Apr 24, 2010, 10:03 PM   #25
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,483
Default

I took my 12-60 out for the first real test today, and I am sending it back as the aperture mechanism does not appear to be calibrated correctly. All the outdoor images I shot looked noticeably too dark, so I started doing some comparison shooting with the 12-60 and 50-200 at the same focal length and exposure and files shot with the 12-60 were visibly too dark for the bright light I was shooting in, using both my E30 and E620.

I held off doing the online survey Olympus sent until I had a chance to use the lens and, as a result, just gave them some pretty low marks across the board for not doing a better job of making sure the new parts they installed were operating correctly before shipping the lens back.

Last edited by Greg Chappell; Apr 24, 2010 at 10:05 PM.
Greg Chappell is offline   Reply With Quote
Old Apr 25, 2010, 7:23 AM   #26
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Oh no! I haven't tested mine yet...better do that today. Everything looked fine through the view finder, but I'll have to test it... Not feeling good about this now...
Kiki FL is offline   Reply With Quote
Old Apr 25, 2010, 9:20 AM   #27
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Just took a couple of test shots with mine that seemed OK, so I guess I've been spared sending it back again.

The down side of this whole thing is that I was really satisfied with the entire Olympus experience until running into "the wall" of ignorance that is tech support. Still love my camera, though.
Kiki FL is offline   Reply With Quote
Old Apr 25, 2010, 10:22 AM   #28
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

Gee wee, more than 1/3 the price of a new lens...Oly knows they can charge that much I guess. That's the problem with expensive equipment. You can't simply buy a replacement unit (well, you can but...it will cost you 3 times more!).
__________________

Tullio
Tullio is offline   Reply With Quote
Old Apr 25, 2010, 10:48 AM   #29
Junior Member
 
Join Date: Jul 2008
Posts: 13
Default

Update: Just attempted to take the survey that's referenced on the Repair Service Packing Slip and it was closed. Looks like you broke it, Greg.
Kiki FL is offline   Reply With Quote
Old Apr 25, 2010, 11:16 AM   #30
Senior Member
 
tkurkowski's Avatar
 
Join Date: Apr 2007
Location: Maryland, USA
Posts: 3,625
Default

Quote:
Originally Posted by Kiki FL View Post
Looks like you broke it, Greg.
Well I can hardly blame him if he did. His repair experience sucks.

Ted
tkurkowski is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:20 AM.