Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus Micro Four Thirds

Reply
 
Thread Tools Search this Thread
Old Jun 4, 2012, 1:32 AM   #1
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default E-PL1 with EOS to M4/3 adapter and Canon EF 50mm F/1.8

The adapter came in yesterday and tested it with the Tamron 70-300mm. It works ok with vignetting on some focal lengths. It does not work well with 24-105mm F/4 L lens as it shows serious vignetting in most focal lengths. However, it works the best with EF-50mm F/1.8.
Attached Images
 
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Sponsored Links
Old Jun 4, 2012, 8:07 PM   #2
Senior Member
 
James Emory's Avatar
 
Join Date: Oct 2011
Location: Bay City, MI
Posts: 2,380
Default

Have you tried it without the lens hood. If I take close pics with my 40-150 Oly lens with hood, I get vignetting, without the hood I do not.
__________________
Olympus OMD-M5, HLG6 grip, Olympus 4/3rd 35mm macro lens, Panny/Leica 25mm, f1.4, Olympus 17mm, Canon Pro 9000 Mk II Printer, Canon MP990 Printer, Slik U212 Tripod, Manfrotto monopod, MMF3 converter.
James Emory is offline   Reply With Quote
Old Jun 5, 2012, 1:00 AM   #3
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default

James,

I play with the adapter some more after reading your reply. Taking off the lens hood does not after the performance of the lens. It has everything to do with the aperture setting on the adapter.

With the EF-50mm f/1.8, it works on all aperture settings and no vignetting is experienced.

With the EF-24-105mm f/4 and the Tamron 70300mm f/4-5.6, there is vignetting from f/11-22 but from f/8-2.8, it works ok. The aperture settings on the adapter are not the exact apertures like that on a lens. They are just some arbitrary settings and I don't know how accurate they are.

Anyway, the weather here is sort of bad. It seldom rains at this time of the year but it did today and the last few days had been windy. I will make some test shots when the weather is better.
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Jun 5, 2012, 1:06 AM   #4
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default

I actually took a couple shots in my backyard with the Tamron 70-300mm f/4-5.6. Somehow, I made a mistake by posting it in the Panasonic M4/3 forum. I left it there since the adapter is also compatible to Panasonic M4/3 cameras. Here is the link:
http://forums.steves-digicams.com/pa...-70-300mm.html
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:49 AM.