Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Sep 20, 2006, 10:29 AM   #1
Junior Member
 
Join Date: Sep 2006
Posts: 3
Default

I have a C-720UZ and some dust/dirthas got inside the Electronic View Finder.

It doesn't appear on the LCD or on photos....it's diffinately in the EVF

Can anyone give me a clue how to get inside to blow the dirt/dustaway?

I've taken 6 screws out now and it still seems to be 'solid as a tank' :angry:

AdvTHANKSance

Channelman
Channelman is offline   Reply With Quote
Sponsored Links
Old Sep 20, 2006, 11:06 AM   #2
Junior Member
 
Join Date: Sep 2006
Posts: 3
Default

UPDATE

I've put the 6 screws back and taken out the 4 under the USB and card covers.

Now I've managed to get the back off but the EVF seems to be a sealed

black unit. Any suggestions?
Channelman is offline   Reply With Quote
Old Sep 23, 2006, 4:48 PM   #3
Member
 
Join Date: Aug 2005
Posts: 55
Default

If you are interested how to disassemble your camera follow this link. It is for Oly 700UZ but I think it might be usefull.
Good luck!
mguergov is offline   Reply With Quote
Old Oct 11, 2006, 8:26 AM   #4
Junior Member
 
Join Date: Sep 2006
Posts: 3
Default

Thanks for the link mguergov
Some of those pictures are quite frightening :shock:

but I'm going to tackle this problem with the EVF,

it doesn't look too diffucult :roll:

Thanks again, Channelman

Channelman is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:16 AM.