Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jun 17, 2003, 11:29 PM   #1
Junior Member
 
Join Date: Jun 2003
Posts: 9
Default How was your experience with Olympus repair?

My new C5050 shows no signs of life. I've read at least four forums fairly thoroughly and tried all the fixes that others have recommended to no avail. It is now in a box ready to be sent off to the Repair Center in New York state. I've only had the camera for 12 days. It worked for 8 and I've been looking for answers for the other 4. I've had such a wonderful experience with my first Oly digicam (an Uzi) that I never dreamed there were as many problems as I discovered when I started reading these forums. Many of the complaints are about poor Olympus service. Am I sending my camera into a black hole, or will I get it back in 2 or 3 weeks as promised?
c5050andanuzi is offline   Reply With Quote
Sponsored Links
Old Jun 18, 2003, 1:07 AM   #2
Senior Member
 
Join Date: Dec 2002
Posts: 331
Default

Maybe you should try exchanging it at the store you purchased it from before sending it to olympus.
ardvark50 is offline   Reply With Quote
Old Jun 18, 2003, 10:24 AM   #3
Member
 
Join Date: Feb 2003
Posts: 52
Default

I am not sure if anyone else had the problems I did, but when I was having problems with my Oly D-520, I sent it in to the New York repair center and they sent it back saying there was nothing wrong with it. So then I sent it in again, this time to the California repair center and they replaced a circuit board. I dont know if the NY office missed somthing or what, they totally overlooked my note I had sent with the camera stating what the problem was, where as the California center wrote down exactly what was wrong with the camera, and not to mention they were a lot more friendly on the phone. I got my camera back within 3 weeks of sending it out both times, just make sure you write down the serial number on the bottom of the camera so you can check the status online through there website.

Good luck!
djkothbauer is offline   Reply With Quote
Old Jun 18, 2003, 12:37 PM   #4
Senior Member
 
Join Date: Sep 2002
Posts: 3,585
Default

I had to send a camera to the CA repair facility. I overnighted the camera. They kept the camera for 2 days for repair and overnighted back to me.
gibsonpd3620 is offline   Reply With Quote
Old Jun 18, 2003, 6:10 PM   #5
Junior Member
 
Join Date: Jun 2003
Posts: 9
Default

I read somewhere that they will ship it back to you the same way you sent it to them.

I now have an address label printed for the East Coast shop and one for the West Coast shop. I'd like to see at least one or two more testimonials, good or bad, before I decide where to send it.
c5050andanuzi is offline   Reply With Quote
Old Jun 19, 2003, 9:30 PM   #6
Junior Member
 
Join Date: Jun 2003
Posts: 9
Default

Thanks to the post above, my camera is on its way to California. I hope this mishap turns into a happy tale and not a horror story. I typed my note describing the problem and added a P.S. graciously asking them to upgrade the firmware if there was a benefit. Of course, I'll let you know how it turns out. The biggest difference I'll notice is if it lights up. Beyond that, I can't promise anything. I only took 2 or 3 dozen photos with it before it went to sleep.
c5050andanuzi is offline   Reply With Quote
Old Jun 23, 2003, 1:44 AM   #7
Senior Member
 
marcoangels's Avatar
 
Join Date: Sep 2002
Posts: 243
Default

I sent my 490Z to the NY repair center and had it back, in working order, in about a week....cudos to them!!!!
marcoangels is offline   Reply With Quote
Old Jun 23, 2003, 2:10 AM   #8
Junior Member
 
Join Date: Jun 2003
Posts: 6
Default

Quote:
Originally Posted by gibsonpd3620
I had to send a camera to the CA repair facility. I overnighted the camera. They kept the camera for 2 days for repair and overnighted back to me.
:?: What was wrong with your cam before they fixed it?
Edward_dee is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:49 PM.