Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jul 25, 2003, 5:51 PM   #1
Member
 
Join Date: Nov 2002
Posts: 52
Default Very low picture quality on my refurb C-5050... please help!

Greetings all,

I got my Oly C-5050 that I got off ebay and it is a refurb. the company is telling me to go through Olympus and if they say it's defective that they (company I got it from) will replace it. I have a 10 day warrenty from them and if I were to send it to Olympus there is no way they could recieve it, test it and send it back to me by the 2nd of Augest.

I paid almost 600 dollars for this and while I do have a 5 year warrenty from a 3rd party and a 90 day warrenty through Olympus I was going to lend this camera to my parents who are going out of the country for nearly 3 weeks starting the 2nd of augest.

Anyways, the camera picture quality is super grainy and pixelated and with funzzyness on the edges on SHQ, TIFF and RAW formats and I tested them all with the ISO ratings the camera has. I also tried it with flash on auto, on and off.

If I had a website other than geocities I'd upload them for you to see what I mean but I don't.

Anyways, my old Fuji finepix 2650 had at least 5 time better picture quality than this til the flash and lens decided to go out of sync.

I'm not a rich person... I make less than 200 dollars a paycheck which is every two weeks. What can I do about this?

Thanks,
Joe
JoeBoeing is offline   Reply With Quote
Sponsored Links
Old Jul 25, 2003, 6:29 PM   #2
Junior Member
 
Join Date: Jul 2003
Posts: 13
Default

Sorry to here of your problems...I myself would send it to Olympus and you can also purchase an extended warranty though Olympus that will give you another two years warranty on the refurbed product. Olympus is always selling stuff on Ebay and the extended warranty for refurbs is no different. Olympus Extended Warranty This lists the extended warranty that Olympus themselves is selling on Ebay.

I will say that the amount you paid seems high for a refurb, I bought a brand new C-5050 including extras for $659 from Cameta (see this link) My C-5050 Ebay Purchase

You really goota watch who you buy from on Ebay...for less than that youi could have bought a refurb from Olympus themselves though Ebay.

Take Care and good luck!
Altaman is offline   Reply With Quote
Old Jul 25, 2003, 7:25 PM   #3
Member
 
Join Date: Nov 2002
Posts: 52
Default

Thanks for the reply.

Well the camera was $509.00, buy it now and it came with a 128MB CF card, cleaning kit and a very very nice case... insurance was about 10 bucks for the shipping and the 5 year warrenty was about 65 bucks.

So, I should just send it to Olympus instead of this place I got it from?

The warrenty I got was from Mack video and camera service... I think that is them.

I have to wait til monday before I can contact Olympus because their department I need to talk to is closed on weekends.

I was going to let my parents take my camera to Europe with them but not in this condition... they are leaving on the 2nd of Augest.

I await more opinions on this matter.

From,
Joe
JoeBoeing is offline   Reply With Quote
Old Jul 25, 2003, 10:39 PM   #4
Junior Member
 
Join Date: Jul 2003
Posts: 13
Default

The reason I say to send to Olympus is you do not really have many options...by 10 day warranty do you mean money back if you are not happy, replacement or they will send for repair? If it is a case of them willing to send you a new camera, or give you your money back I would go that route...otherwise yes just let Olympus fix it.
Altaman is offline   Reply With Quote
Old Jul 26, 2003, 12:07 AM   #5
Member
 
Join Date: May 2003
Posts: 40
Default a couple of suggestions

first i'd check out the firmware on your camera. while i am not a 100% believer in many of the stories floating about with regards to it, if you do have v77, there seems to be a general consensus that this version implements an overaggressive sharpening algorithm.

on my v77 i have the following settings: spot focus, ESP metering, sharpness -4, contrast -1, saturation +1. try these settings and see if the graniness still persists. i also shoot mostly in RAW format (memory allowing), and drop down to SHQ or HQ (native resolution (not 3:2 or enlarge) if i start to run low. some have talked about quality benefits of the enlarge mode, but i personally do not like it.

my 5050 pictures are sharp from end-to-end, so i am not sure about your fuziness at the edges problems. however if i use an add-on lens, which at the moment is a rather cheap vivitar 2.5 telephoto, fuziness is to be expected at the edges. for better results with an addon, try the olympus tcon17 (telephoto) or wcon07 (wide angle).

lastly i'd also look into purchasing the extended warranty from olympus while your current warranty is still valid. they do not offer this in my country but i believe that you can purchase this extended warranty at _any time_ before your current warranty with them runs out. do it now and be safe. you also get a free cleaning/alignment of the camera with this purchase, which is nothing to be laughed at a year or three down the road.

anyway, in my case, it took me a while to learn the camera and get good pictures from it. at the start my pictures were rather horrible too, and i hope you don't get discouraged. however, handing it over to your parents without having them learn it first is a path filled with potential dangers. hopefully they are familiar with the various settings, if not i'd just set it to P mode (with whatever sharpness/saturation/contrast settings you settle on) and keep it there. hope this helps =)

Somy
somynex is offline   Reply With Quote
Old Jul 26, 2003, 10:19 AM   #6
Member
 
Join Date: Nov 2002
Posts: 52
Default

Thanks for the advice... how do I go about checking the firmware version?

The quality of this is horrid... I mean it's like a bad 1st gen sub 1 megapixel camera but with a larger picture.

I can e-mail the pic to someone if they think they can help but it's like 3 MB. I just don't have a site to host it on that can handle such bandwidth.

I contacted Olympus and the guy was nice and told me to e-mail them a pic and that they will get back to me on Monday. So, I hope all goes well.

Thanks all and I'll look into that Olympus Warrenty.

Sincerely,
Joe Boeing
JoeBoeing is offline   Reply With Quote
Old Jul 26, 2003, 10:27 AM   #7
Member
 
Join Date: May 2003
Posts: 40
Default

Hi Joe,

I personally do not think my e-mail can handle a 3MB attachment but you can consider signing up for a geocities account and just posting it there. if you have a yahoo e-mail then you automatically get an account if not, just sign up for a new one and use it.

to check the firmware version, open any original (some editors that do not support the exif information may remove it from the file) picture taken from the camera and check the exif info. should you not have a viewer that can check such info, download irfanview or exifer to check this info. irfanview's homepage is at www.irfanview.com, while you'd have to search for exifer as i do not use that program. the firmware version will be displayed in the exif info.

i hope you will reach a satisfactory conclusion with your camera. despite an initially steep learning curve, i am very happy with my 5050 now, and am still learning more every day =)

all the best,
Somy
somynex is offline   Reply With Quote
Old Jul 26, 2003, 2:43 PM   #8
Member
 
Join Date: Nov 2002
Posts: 52
Default

Okay... I uploaded it to my geocities site and I posted the settings the photo was taken with above the pic.

This is the best pic I got from this camera.

If it doesn't come up I ran out of bandwidth for an hour so please try again.

I'm going to DL that software to see which firmware version I have right now.

FRom,
Joe
JoeBoeing is offline   Reply With Quote
Old Jul 26, 2003, 2:55 PM   #9
Member
 
Join Date: Nov 2002
Posts: 52
Default

I don't see a "Firmware" on the file... I do see a software version number. It says Software v558.76. Is that it?

From,
Joe
JoeBoeing is offline   Reply With Quote
Old Jul 26, 2003, 11:13 PM   #10
Senior Member
 
marcoangels's Avatar
 
Join Date: Sep 2002
Posts: 243
Default

Try www.pbase.com. I've uploaded 11k tiff files with no problem...blessings, Johnny
marcoangels is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:33 AM.