Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Oct 13, 2008, 10:57 AM   #31
Junior Member
 
Join Date: Jun 2008
Posts: 15
Default

HMM...i LOVE my 570 uz..and I am trying to get used to the zoom..my main problem is that SOMETIMES it doesn't seem to respond...and then when it does it's fabulous..is this normal?? I am asking in case I have a camera that needs to be returned while under warranty.

Otherwise I think I am loving this one...much, much better than the 550 uz....I love the size, the feel etc..love the zoom and even more with the TCON! i WILL POST A COUPLE OF pix I took over the weekend soon!


shersart is offline   Reply With Quote
Old Oct 23, 2008, 11:02 AM   #32
Junior Member
 
Join Date: Aug 2008
Posts: 13
Default

hi all, I bought my 570 in July and I think it's great, however I seem to be sticking to the same settings, and not being very adventurous. I bought it mainly for taking pictures of my sons rugby matches.

Can I ask what settings you guys find best for shooting fast movig subjects.

Sandra
slipperyjoe is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:47 AM.