Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jan 10, 2004, 3:04 AM   #1
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default External light for C-720

I bought a external light for my Olmpus C-720. It's a OMEGA DIGIFLASH. Having my internal light and external light turned on, my photos are dark. When I use the internal light I don't have that problem. I thought the external light will help with red eye and better pitchers. Can someone please tell me what i maybe doing wrong?
Imacer is offline   Reply With Quote
Sponsored Links
Old Jan 10, 2004, 8:58 AM   #2
Senior Member
 
Join Date: Oct 2002
Posts: 157
Default

A quick guess - Are you using "red-eye" reduction flash mode which has a pre-flash just prior to shutter release along with a "main" flash? I believe that the camera does some exposure measuring with the pre-flash and if your external flash is going off with the pre-flash, then the camera is saying "There's a lot of light here so let's shorten the exposure." Hence, the dark picture.

Try turning off the "red-eye" flash mode.

If you want to use the "red-eye" reduction mode, make sure the Omega Digiflash is capable of the handling a pre-flash and it is set to go off on the second flash, i.e., when the shutter is released.

I read of a simple test for all this a while back - take a video (using a camcorder) of the flashes going off. Easy way to check to see when the external flash is going off with respect to the camera's internal flash.

Paul in NoVA
C-730 B-300 WCON-07
plg3 is offline   Reply With Quote
Old Jan 10, 2004, 3:40 PM   #3
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default

I am not using the red eye reduction at all. I just pop my internal light so the external will work.
Imacer is offline   Reply With Quote
Old Jan 15, 2004, 9:32 PM   #4
Senior Member
 
Join Date: Oct 2002
Posts: 157
Default

Well, I must admit that I'm stumped on this one. But as my "significant other" would add, I'm not the brightest light bulb in the pack. And I was hoping that some of the regulars here might have other suggestions.

Have you tried your external flash with your C-750? Similar results?

Paul in NoVA
C-730 B-300 WCON-07
plg3 is offline   Reply With Quote
Old Jan 15, 2004, 11:25 PM   #5
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default

Plg no I have not. I returned the light I bought for my C-720. Light did not come on at the same time as the internal light, so I returned it. I just bought the C-750 and have got a light yet. In the works getting one.
Imacer is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:46 AM.