Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Feb 22, 2018, 5:25 PM   #1
Senior Member
 
Join Date: Jun 2002
Location: Victoria, B.C., Canada
Posts: 999
Default Olympus SP-350 battery problem

If anybody still has an SP-350 and NiMH rechargeable batteries work very poorly I may have found both the cause and a remedy. NiMH batteries are rated at only 1.2 volts each. So a pair of them deliver only 2.4 volts and for the SP-350 that is hopelessly inadequate.

The SP-350 needs a total of 3 volts. A non rechargeable Lithium battery is rated at 1.5 volts so a pair of them deliver the necessary 3 volts.

My SP-350 has been working just fine since I switched, a couple of weeks ago, to the Lithium batteries. Even better, I found a source of the Lithium batteries that cost only $1.50 each.
Herb is offline   Reply With Quote
Sponsored Links
Old Feb 23, 2018, 8:36 AM   #2
Senior Member
 
Steven R's Avatar
 
Join Date: Apr 2005
Location: Tampa, Florida
Posts: 5,913
Default

Hi Herb: Glad that you found a solution.
Steven R is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:28 PM.