Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old May 10, 2004, 2:00 PM   #1
Member
 
Join Date: Sep 2003
Posts: 50
Default

wide

http://homepage.ntlworld.com/km.bates/tower%201.jpg

10x

http://homepage.ntlworld.com/km.bates/tower%202.jpg

14x

http://homepage.ntlworld.com/km.bates/tower%203.jpg


others

http://homepage.ntlworld.com/km.bates/Elvaston2004/index.htm

comparison with FZ10, C-750 and C-770 images on http://www.kevin-bates.co.uk

I would also like to clarify the battery situation I have only had to charge the supplied battery once to take 480 shots and spares are not expensive in the UK ranging from £7 on Ebay to £14 at 7dayshop.com

Compared to my C-750 and FZ10 I am very satisfied with the C-770. :-)


blackthorn is offline   Reply With Quote
Sponsored Links
Old May 26, 2004, 3:57 PM   #2
Junior Member
 
Join Date: Apr 2004
Posts: 4
Default

Hello,

I am wondering how you got so many pictures from one battery charge. I just received my 770 last week and my battery died after about 30 shots! What am I doing wrong??

Thanks,

Jill
jill1964 is offline   Reply With Quote
Old May 26, 2004, 6:33 PM   #3
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

Did you charge the battery first? As well, sometimes it takes two or three charges until a new battery gets conditioned to fully charge.

- Check out the Oly_C-700 Yahoo Group, discussions, fun challenges for ALL C-7x0 users, http://groups.yahoo.com/group/Oly_C-700/

- Member of the Toronto Camera Club, http://www.torontocameraclub.com/
Mikefellh is offline   Reply With Quote
Old Jun 7, 2004, 4:16 PM   #4
Junior Member
 
Join Date: Apr 2004
Posts: 6
Default

According to the manuals for LI-ION batteries, you need to charge and discharge them 2-3 times before they will see their full potential...

I took my camera for a weekend trip, took 300M worth of pictures (150) with plenty of flash use, tons of LCD use, etc. and the battery didn't run low till I was downloading the pictures later.
lostlogic is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:06 PM.