Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old May 29, 2004, 3:57 PM   #1
eal
Member
 
Join Date: May 2004
Posts: 45
Default

Greetings all--

I've inherited a C2100 from my dad after it got wet, and really, he just wanted another camera(New Sony 8Megapixel) so here is the problem. We noticed that there are focusing problems and after switching to manual focus I see that it can't focus under 1M. I can here the motor "trying" to focus, but no luck? It is out of warrenty, and if possible I would like to fix it myself. I am thinking though that sending it to Olympus(with $200) is my only option. Any suggestions? Is it really worth spending that much, or better off just putting the 200 towards another camera.

Thanks for your help.



eal
eal is offline   Reply With Quote
Sponsored Links
Old May 29, 2004, 5:21 PM   #2
Senior Member
 
Join Date: Jun 2002
Posts: 508
Default

Sounds like your not in macro mode. If not, enable it


sdromel is offline   Reply With Quote
Old May 30, 2004, 2:37 PM   #3
eal
Member
 
Join Date: May 2004
Posts: 45
Default

That is what I thought also, but even in macro mode it still won't focus correctly. I've tried to manual focus in both macro and normal; it actually stops moving the little green bar showing your focal length at 1M eventhough there is 60cm, 30cm and 10cm settings below it on the screen/viewfinder.

eal
eal is offline   Reply With Quote
Old May 31, 2004, 12:35 AM   #4
Senior Member
 
Join Date: Jun 2002
Posts: 508
Default

I can make my C2100 act like yours. If the Tele (ie, Zoom) is stopped anywhere
in the last 20-25% of the Zoom range (as estimated on the verticle zoom bar - left hand side of display), then the MF slider scale will transition to show the close range scale (ie, 1m, 60cm, 30cm, 10cm markers), but will not reduce (ie, move) below the 1m mark.

Setting the zoom to full wide then setting the MF to min range (ie, 10cm) then zooming toward full Tele results in the MF pointer being automatically moved (increased MF distance) in the viewfinder. The MF pointer gets picked up (for movement to increase focus distance) at about the 60% Tele mark.

If your unit can't MF below 1m, then I suspect that some type of internal limit switch has gone bad (ie, thinks the zoom is >75% Tele). Try tapping the camera with your knuckles to see if you can free anything which might be stuck inside. If that doesn't work then it looks like you'll have to send it in for repair or just don't use MF mode.

sdromel is offline   Reply With Quote
Old May 31, 2004, 10:02 AM   #5
eal
Member
 
Join Date: May 2004
Posts: 45
Default

Hmmm, maybe I'm expecting more from the camera then it is able of doing(however my dad did say that he noticed a problem after it got wet) On macro and tele I can't focus on my computer monitor while the camera is 12" away(af or mf).

So, let me ask you this, if your camera had the same problem, would you send it in? Or put it towards a new one and just keep it as a backup. Just curious.

eal
eal is offline   Reply With Quote
Old Jun 1, 2004, 5:44 PM   #6
Senior Member
 
Join Date: Jun 2002
Posts: 508
Default

I would live without the macro/close up capability and not have the unit repaired until it got sufficiently worse. If you send it in for repair, OLY may send you a different C-2100 which you may or may not like. In any event, they will upgrade the firmware (probably to ver 76) which you may or may not like.

The OLY is a great camera even by today's standards. Enjoy it while you have it. Also, who knows, thru use, there is an outside chance that the unit will begin functioning correctly again.


sdromel is offline   Reply With Quote
Old Jun 1, 2004, 7:59 PM   #7
eal
Member
 
Join Date: May 2004
Posts: 45
Default

Hmmm, I was afraid you would say something like that...the problem is that macro is what I want to do the most...I think I may have to take the chance....The camera was free so I guess I can't complain to much.

eal
eal is offline   Reply With Quote
Old Jun 1, 2004, 9:23 PM   #8
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

eal wrote:
Quote:
On macro and tele I can't focus on my computer monitor while the camera is 12" away(af or mf).
It's not supposed to be able to focus that close using zoom.

At full wide angle, your camera can focus as close as 10cm (~ 3.9 inches) in macro mode. However,at full zoom, the minimum focus distance in macro modeincreases to 100cm ( ~ 39 inches).

So, the question is, are you using zoom, as you implied when you said "On macro and tele"?

If so, then you'll be wasting your money sending your camera in for service, as there is probably nothing wrong with it.

Check out how close it can focus at wide angle. If it can focus down to 10cm (~ 3.9 inches) at full wide angle (but not at longer focal lengths), then it's working normally.


JimC is offline   Reply With Quote
Old Jun 3, 2004, 10:12 PM   #9
eal
Member
 
Join Date: May 2004
Posts: 45
Default

Interesting...my measured distancesare close(within a couple of inches) of what you said above.I trust my dad though, he is not a camera newbie such as myself, and he owned the 2100 since it came out until about a month ago. I think I'm going to take a chance and send it in.My dadsaid he noticed the problem first when trying to take a picture of an orchaid for use in an art class. I thank all of you for you help. I will be sure to post some picks for comparison soon.

eal
eal is offline   Reply With Quote
Old Jun 4, 2004, 7:17 PM   #10
Member
 
Join Date: Dec 2003
Posts: 66
Default

You might want to check on any policies regarding water damage before spending the money to send it in. Most places will simply refuse to repair any electronic device that has water damage.

KuoH
KuoH is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:09 PM.