Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Aug 9, 2004, 8:08 PM   #1
Junior Member
 
Join Date: Jul 2004
Posts: 3
Default

Sent in my 8080 for repair today. Had it on the macro setting and was taking shot stright down when the AF starts making buzzing/grinding noises from the lens barrel. AF and MF became inoperative and I twice got a "Zoom Error" message.

This stinks - loved the camera while it worked; hope it can be repaired under warranty.

Anyone else heard of this type of problem?
ke72jak is offline   Reply With Quote
Sponsored Links
Old Aug 10, 2004, 7:10 AM   #2
Senior Member
 
MVASteve's Avatar
 
Join Date: May 2004
Location: Adelaide South Australia
Posts: 793
Default

So far Iam feeling very lucky with my C8080 as i have had no problems with the camera, except for the slight red flaring in the LCD minitor during certain lighting conditions.But Iam concerned that there seem to be a few more posts lately with C8080 cameras that have faults. Are there faults with other brand digital cameras? In a way I hope so and its not confined to Olympus products.
I have had my camera now for approx 15 weeks and it has even had a couple of knocks. Better to have problems early than later when warrenties expire.
Hope all goes well with your camera ke72jak.
MVASteve is offline   Reply With Quote
Old Aug 10, 2004, 11:14 AM   #3
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

Repairs??? Should have asked for advice first...the DEALER should be the one replacing it with another 8080. If you owned the camera less than a week, it should be replaced by the dealer, not repaired.

I know this is no consolation, but something like this can happen with any camera make or model...maybe yours was dropped in shipping.
Mikefellh is offline   Reply With Quote
Old Aug 15, 2004, 3:03 AM   #4
Senior Member
 
John G.'s Avatar
 
Join Date: Jan 2004
Posts: 248
Default

Totaly agree Mike
However maybe it was given as a " Gift " and the dealer unknown.
Many situations Ex. husband separates/disapears from wife 2 days after giving camera. OR vice a versa :-(
John G. is offline   Reply With Quote
Old Aug 19, 2004, 8:07 PM   #5
Junior Member
 
Join Date: Jul 2004
Posts: 3
Default

Just got the the Oly back from Olympus America and couldn't be happier! works great after having the entire lense assembly replaced. I have to say that the turnaround was impressive. I mailed it overnight 8/9 and i received it fixed on 8/19 - 10 days, start to finish.

The only complaint I have is about the tracking. I never got a call or e-mail about the camera, and on their service and repair part of their website, the info on the camera only appeared for two days with nothing other than the fact that they had it.

Regardless - my expectations on the timeframe were exceeded! Now I can't wait to start taking snaps!

You live - you learn.
ke72jak is offline   Reply With Quote
Old Aug 19, 2004, 9:24 PM   #6
Senior Member
 
MVASteve's Avatar
 
Join Date: May 2004
Location: Adelaide South Australia
Posts: 793
Default

Glad all things went positively, enjoy your new camera.
MVASteve is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:32 AM.