Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Oct 12, 2004, 1:01 AM   #1
Member
 
Join Date: Dec 2003
Posts: 32
Default

I have just finished my research for getting an external flash for my 5050. Unless I can find a used FL40 for $200, I am going with the Promaster 5750DX. Does anyone here with a 5050 use a Promaster? What's your experience with it?
cram33 is offline   Reply With Quote
Sponsored Links
Old Oct 12, 2004, 11:01 AM   #2
Member
 
eddie_kirst's Avatar
 
Join Date: Jan 2004
Posts: 66
Default

I use the 5750 on an Olympus C-750. I love it. Its very powerful. I often use it on sunny days as a fill in flash. Does great family photos with the bounce mode. No shadows. I like to try with and without its built in fill flash. Totally automatic too.



ed
eddie_kirst is offline   Reply With Quote
Old Oct 12, 2004, 1:01 PM   #3
Member
 
Join Date: Sep 2004
Posts: 51
Default

Ed:

I was going to get a 5750 for a C-750 till I read some posts that the autofocus assist light does not work properly with C-7xx series cameras. They said it shuts off too soon, before the camera can get focus lock.

How well does the autofocus assist light work with your C-750?


segbert is offline   Reply With Quote
Old Oct 12, 2004, 1:28 PM   #4
Member
 
Join Date: Dec 2003
Posts: 32
Default

I read that also in a post somewhere. But in this review (great one) it wasn't mentioned.

http://wrotniak.com/photo/c5050/pro5750.html
cram33 is offline   Reply With Quote
Old Oct 12, 2004, 1:31 PM   #5
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

It's a C-7xx issue due to the long lens...shouldn't be an issue on the 5050 with its super bright lens.
Mikefellh is offline   Reply With Quote
Old Oct 12, 2004, 3:48 PM   #6
Member
 
Join Date: Dec 2003
Posts: 32
Default

Thanks. I found a great price and ordered it!!!!
cram33 is offline   Reply With Quote
Old Oct 12, 2004, 5:16 PM   #7
Member
 
Join Date: Sep 2004
Posts: 51
Default

Hear Hear
Where? Where?
There! There!

Where did you order it, and if you don't mind, how much?
segbert is offline   Reply With Quote
Old Oct 12, 2004, 7:45 PM   #8
Member
 
Join Date: Dec 2003
Posts: 32
Default

segbert wrote:
Quote:
Hear Hear
Where? Where?
There! There!

Where did you order it, and if you don't mind, how much?
I found this place on the internet http://www.cameracompany.com
On the phone they were helpful and friendly. I found the flash WITH THE MODULE for $124.99. That's by far the cheapest I have found.
cram33 is offline   Reply With Quote
Old Oct 12, 2004, 9:06 PM   #9
Member
 
Join Date: Sep 2004
Posts: 51
Default

What a deal!

At that price, I'd try one for my C-750.
Unfortunately, they only have the 'Olympus with cord' module, but not the 'Olympus hot shoe' module.

Bummer.
segbert is offline   Reply With Quote
Old Oct 12, 2004, 9:22 PM   #10
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

segbert wrote:
Quote:
At that price, I'd try one for my C-750.
Unfortunately, they only have the 'Olympus with cord' module, but not the 'Olympus hot shoe' module.
cram33 wrote:
Quote:
I found this place on the internet http://www.cameracompany.com
On the phone they were helpful and friendly. I found the flash WITH THE MODULE for $124.99. That's by far the cheapest I have found.
Cram, you did order the proper module for you camera, didn't you? The C-5050 requires the hotshoe module, not the cord module.
Mikefellh is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:29 AM.