Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Nov 29, 2004, 4:41 PM   #1
Junior Member
 
Join Date: Nov 2004
Posts: 5
Default

[align=left]I have been using my C750 for about a year with no problems. All of a sudden, while I was at a wedding this weekend, I was trying to scroll through the menus with the four cursor buttons surrounding the menu button on the back of the camera. It was as if the cursor buttons froze out of the blue. I tried everything to get the buttons to work again, but no luck. I can open the menu fine, but when I go to scroll through the menu, the buttons don't respond. Nothing happens at all. I looked through all of the troubleshooting guides and instruction manual, but no luck whatsoever. I think my warranty may just about have expired, so I was hoping there might be something I overlooked before I send it to the shop and pay a few hundred dollars!!!! Ouch!!!Can anyone help??? Thanks, Eric...[/align]
ericrazavi is offline   Reply With Quote
Sponsored Links
Old Nov 29, 2004, 6:15 PM   #2
Senior Member
 
Join Date: Nov 2003
Posts: 162
Default

Remove the batteries for 24 hours so that the camera resets; try again.


jkusmier is offline   Reply With Quote
Old Nov 30, 2004, 11:03 AM   #3
Junior Member
 
Join Date: Nov 2004
Posts: 5
Default

Thanks, I will try that and let you know what happens...
ericrazavi is offline   Reply With Quote
Old Nov 30, 2004, 1:02 PM   #4
Junior Member
 
Join Date: Aug 2004
Posts: 7
Default

I had a similar problem with my 750, the 3 buttons above the power button would cause it to take a picture sometimes. It was under warranty and National Camera loaned me one for my vacation.

BL
BrettL is offline   Reply With Quote
Old Nov 30, 2004, 1:24 PM   #5
Member
 
Join Date: Sep 2004
Posts: 51
Default

You can also try an immediate reset via the camera control menu:

1. Put it in P on the mode dial

2. Open the flash card door

3.Press the OK (in the center of the directional arrows) and the LCD (the |O| one you press to go from LCD to viewfinder) buttons at the same time and hold them down for several seconds. On some models it matters which one you press first, so try both ways.

4.You get a special menu that says USB (for selecting camera control or storage access modes) and Camera

5. Select Camera, then select Reset
segbert is offline   Reply With Quote
Old Nov 30, 2004, 2:09 PM   #6
Junior Member
 
Join Date: Nov 2004
Posts: 5
Default

I will try what you said...I hope it works, because sending it back to Olympus is a hassle. Already had to do it once!!! And I hardly ever use the camera!!!!
ericrazavi is offline   Reply With Quote
Old Nov 30, 2004, 2:28 PM   #7
Junior Member
 
Join Date: Nov 2004
Posts: 5
Default

I tried the camera reset that you told me about, but unfortunately when I get to the camera/usb menu, the arrows will not allow me to move to the "camera" caption so I can reset the camera.
ericrazavi is offline   Reply With Quote
Old Nov 30, 2004, 3:29 PM   #8
Member
 
Join Date: Sep 2004
Posts: 51
Default

Well, all you can do is leave the batteries out for 24 hours.

You have made sure that none of the buttons are stuck?
Sometimes this kind of button will get tilted or something and get mechanically jammed in the pressed position. I have not encountered this with my C-755, but it has happened occasionally on other things with similar buttons, like remote controls. Make sure they all pop in and out when you press them. If one doesn't, you can usually coax it to pop back up.
segbert is offline   Reply With Quote
Old Nov 30, 2004, 4:01 PM   #9
Junior Member
 
Join Date: Nov 2004
Posts: 5
Default

No...buttons are not stuck. I guess I will let you know what happens in 24 hours. Let's hope it works. Thanks for all your help though...I appreciate it!!!
ericrazavi is offline   Reply With Quote
Old Jan 4, 2005, 1:35 AM   #10
Junior Member
 
Amethyst's Avatar
 
Join Date: Dec 2004
Posts: 8
Default

hi,

I have the c750 and love the thing. I have been able to take some nice photos with the full 40x zoom handheld which I didn't really think would give me a clean, focused shot.

Is there a link to a site with the "secret camera tricks" like this one described here. would love to read them and see what is useful. have never updated the firmwhere from when I bought it. anyone has that can tell me about it? the only thing is that some computers will see my camera to dl photos and some won't - even tho all the computers are windows xp! doesn't seem to matter if sp2 or not. weird thing. My computer at work won't see it at all but my coworkers will. exact same computer. same build at same time. both xp pro. any suggestions? amethyst
Amethyst is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:04 PM.