Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jan 18, 2003, 5:16 AM   #1
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default C50Z Freeze

My C50Z freezes occasionally. Just like Windows on a PC. The camera gets comletely stuck and I have to remove the battery and put it back in to make the camera work.

This is annoying because the date and time will have to be reset.

Has anyone has a solution?
JohnE is offline   Reply With Quote
Sponsored Links
Old Jan 18, 2003, 11:13 AM   #2
Senior Member
 
Join Date: Sep 2002
Posts: 3,585
Default

Is this happening when you are taken a pic? Is it when you are downloading files from the camera to the PC? Little more descripition would be helpful
gibsonpd3620 is offline   Reply With Quote
Old Jan 18, 2003, 4:55 PM   #3
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

Hi

It happens when I am taking pictures. Last time it happened, I had pressed the release button half way down, and when the green focus light and red flash-ready light where steady, I pressed the button all the way down. The camera froze. The display was on, all the indicator lights where on, but I couldn't take a picture or switch the camera off. It simply froze.

I removed the battery and put it back in. Everything worked again, but the date and time had to be reset.

This is the third time it happened in the last twenty days.
JohnE is offline   Reply With Quote
Old Jan 19, 2003, 8:34 AM   #4
Senior Member
 
Join Date: Sep 2002
Posts: 3,585
Default

John

It acts like it can not close the write function to the media. I would try to reformat the media card you are using. I would use a different type of media card (if using xd find a sm or cf card). I suspect if the first procedure does not clear the problem then return it to Olympus or the store you purchased it from. My C4040 froze once and reformatting the card resolved the problem.
gibsonpd3620 is offline   Reply With Quote
Old Jan 19, 2003, 9:19 AM   #5
Junior Member
 
Join Date: Dec 2002
Posts: 8
Default

gibsonpd3620

It's easy enough to format the card, so I'll try it.

But the camera freezes when I press the release button, before it takes the picture and before it tries to write to the card.

A user from another forum says that his c50Z freezes when battery power is low. But that certainly is not the case with mine.

If reformatting the card doesn't help, then it goes back to Olympus[/b]
JohnE is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:18 AM.