Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Sep 17, 2005, 5:39 PM   #1
Junior Member
 
Join Date: Sep 2005
Posts: 1
Default

I few days ago I turned on my Olympus C-5050 Zoom and enabledthe Quick View function. There were dark purple lines (similar to when the tracking is off on a VCR) on the LCD display. When I began to take pictures, the flash was so bright that every picture I took was completely white, unless the picture was of something 15' away or more. Then, you could just make out the outline of what the picture was of because of some light shadows.

Has anyone else had this problem? Can anyone help? I haven't dropped the camera or anything, and it's what's making this problem even more puzzling. What would cause this to just all of a sudden happen?
godkillzyou is offline   Reply With Quote
Sponsored Links
Old Oct 7, 2005, 9:34 AM   #2
Member
 
Join Date: Apr 2004
Posts: 71
Default

There seem to be quite a few CCD failures in the C-5050z.¬*¬*You can go to¬*http://www.moon-stone.com/5050/¬* , where a group of people are trying to get Oly to do something about it by collecting the serial numbers of affected cameras.NB
nellybly is offline   Reply With Quote
Old Oct 22, 2005, 7:16 PM   #3
Junior Member
 
Join Date: Oct 2005
Posts: 7
Default

Ours went bonkers too! We gave up thinking about having it fixed and bought a C-7070 - it's far better than the 5050, so in a way, I'm glad it happened!
scubamom is offline   Reply With Quote
Old Oct 22, 2005, 7:47 PM   #4
Member
 
Join Date: Apr 2004
Posts: 71
Default

Olympus has recalled the C-5050 for a CCD replacement.¬* If you still have it you can have it fixed at no charge.More details here¬*¬*http://www.dpreview.com/news/0510/05...cdadvisory.asp
nellybly is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:09 AM.