Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jan 23, 2006, 12:27 PM   #1
Junior Member
 
Join Date: Jan 2006
Posts: 1
Default

Question:

My Olympus styulus is about a year, maybe a year and a half old and all the sudden we have a red flashing "flash" symbol that wont go away and will not allow us to take picture indoors any more. Normally this light simply indicates that there is not adequate lighting but we have never had this issue before. We have went through all the modes to try and change the settings but the red flashing flash continues. We are able to take pictures out doors but no longer indoors and it's very frusterating when you have a new baby!

Any help would be appreciated!

Ruby
ruby2zdaze is offline   Reply With Quote
Sponsored Links
Old Feb 6, 2006, 11:59 AM   #2
Junior Member
 
Join Date: Feb 2006
Posts: 2
Default

Mine just started doing the same thing. I called tech support and I have to send it in. Not sure how much it will cost but a big inconvenience.
opus is offline   Reply With Quote
Old Mar 16, 2006, 2:40 PM   #3
Junior Member
 
Join Date: Mar 2006
Posts: 1
Default

I have the exact same problem. I took it to a local camera store and they told me it was the flash circuit assembly. The part costs $40 and repair is about $95. I tried to find the part myself to save the exorbitant repair fee, but you can't order it from Olympus unless you're a dealer. And you can't find it online.

So basically, unless someone else chimes in on this thread, we're all stuck with buying a new camera or paying the repair cost.

At least you know what the trouble is now.

:sad:
stonefam is offline   Reply With Quote
Old Jul 4, 2006, 8:18 PM   #4
Junior Member
 
Join Date: Jul 2006
Posts: 1
Default

I have the exact same problem with my stylus 410. Olympus wants $250 to fix it. I'm not sure the camera is even worth this much. Has anyone had there stylus repaired by someone other than olympus? If so, how much did it cost? was the problem resolved? Any information is appreciated. Thanks.
jwoollard is offline   Reply With Quote
Old Jul 4, 2006, 11:59 PM   #5
Junior Member
 
Join Date: Feb 2006
Posts: 2
Default

I had mine repaired by Olympus for $159. I like my remote on this camera and other new ones I looked at did not have it. It has worked great since but obviously this was a problem with this model.
opus is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:41 AM.