Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Olympus

Reply
 
Thread Tools Search this Thread
Old Jul 17, 2006, 10:57 PM   #1
Junior Member
 
Join Date: Jul 2006
Posts: 6
Default

C-8080 red alert light started blinking after taking movie and a coupla stills underwater. Everything jammed. Could not turn on or off. Above water, I replaced battery and then it worked again. Camera jammed again underwater after taking a couple of stills. Worked again after I turned it off, then on. But jammed again immediately after taking another still shot - same deal - red light blinking - couldn't turn it off until I got outa the water and got the camera out of the case and removed battery back on dry land. I was diving with a divemaster who had had a C-8080 for a year and had no problems. I was using camera on P setting. I was using the Olympus u/w housing and there was no leak.

initially this happened underwater. and has happened once above water. My divemaster friend suggested it could be a firmware malfunction and recommended I download and install the firmware again. Is this possible? I have found a firmware update for the C-8080 on Olympus' site, but still unclear if this will help me. Any input on the malfunction described above will be most welcome.

cheers
tubivore is offline   Reply With Quote
Sponsored Links
Old Jul 18, 2006, 12:23 AM   #2
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,520
Default

Are you using some form of silica gel within the housing to keep the humidity down? From a short amount of experience in using a Canon G5 with an underwater housing in the carribeanI read the heat build-upof a digicam inside a housing can be a problem without using some form of dessicant to keep it in check.
Greg Chappell is offline   Reply With Quote
Old Jul 18, 2006, 8:27 AM   #3
Junior Member
 
Join Date: Jul 2006
Posts: 6
Default

yes, Iwas usinga silicon dessicant pack inside the u/w housing. still that may be an angle worth considering when I take the camera to the Olympus tech staff here in Hong Kong this week. thanx
tubivore is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:44 AM.