Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Other Makes

Reply
 
Thread Tools Search this Thread
Old Nov 22, 2006, 11:22 PM   #1
Junior Member
 
Join Date: Nov 2006
Posts: 5
Default

I purchased my Innovage Mini Digital last week at a local Walgreens for $10.00. It came with a USB cable, Carry case, Photo processing software(CD) with driver, Instruction manual. My first attempt to install driver popped a message (Driver Failed) I removed the CD and found a glue smudge which I removed with a soft cotton cloth and rubbing alcohol. I received a new message after attempt #2. The software you are using has either not been digitally signed by the manufacturer or has been improperly signed, contact your vendor. I have the phone # and fax number for Arcsoft Inc. the Innovage parent company. 1-510-440-9901. fax= 1-510-440-1270. I will attempt to call these fine people after Thanksgiving. Will post my results if any immediately. Good luck to all.

vondansand
vondansand is offline   Reply With Quote
Sponsored Links
Old Nov 24, 2006, 10:18 PM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

vondansand wrote:
Quote:
I received a new message after attempt #2. The software you are using has either not been digitally signed by the manufacturer or has been improperly signed, contact your vendor.
That's a common issue installing drivers. Just because Microsoft isn't aware of the drivers existance and it doesn't have Microsoft's "stamp of approval" doesn't mean that it won't work. ;-)

When installing a driver like that, just select the choices to install them anyway if you trust their source (bypass the warnings) and see if they work or not.


JimC is offline   Reply With Quote
Old Dec 1, 2006, 4:01 PM   #3
Junior Member
 
Join Date: Dec 2006
Posts: 2
Default

I just purchased 13 of these for gifts. I decided to try one. I loaded the software (after checking the web site to confirm it had been tested with Windows platforms), but every time I try to download photos, it shuts my computer down. So I called the corporate office (your number). They had a phone routing system, called the tech support number. Tech support couldn't answer my problem without me paying them a fee. Does anyone else have problems with the computer shutting down when trying to load photos from the Innovage mini-digital camera, software by Arcsoft? Does anyone know how I can get ahold of Innovage? I can't find them on the web.

HELP!

Thanks,

Lori


loripowell is offline   Reply With Quote
Old Dec 1, 2006, 6:31 PM   #4
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Check and see if the camera shows up as a removable drive under "My Computer".

If it does, you can simply click on it, navigate to the folder containing your images (click on folders until you get to the one with the image files in it). Then, select and copy them to a folder on your PC.

IOW, if the camera is mass storage compliant, you wouldn't need the software that comes with it (since it would show up just like any other removable disk drive when plugged into to a USB Port). Some cameras are USB Mass Storage Compliant, and some cameras aren't. I don't know if the Innovage cameras are or not.


JimC is offline   Reply With Quote
Old Dec 5, 2006, 11:34 AM   #5
Junior Member
 
Join Date: Dec 2006
Posts: 3
Default

I purchased the 2nd camera from walgreens thinkg that the first one wa defective, and now I know it was notany ideas on how to make this thing work. I know its connected because when the computer start the camera turns on and the lcd says PC. but when I try to download the images the softwear says cannot connect. can you help?
jeroldow is offline   Reply With Quote
Old Dec 5, 2006, 11:34 AM   #6
Junior Member
 
Join Date: Dec 2006
Posts: 3
Default

I purchased the 2nd camera from walgreens thinkg that the first one wa defective, and now I know it was notany ideas on how to make this thing work. I know its connected because when the computer start the camera turns on and the lcd says PC. but when I try to download the images the softwear says cannot connect. can you help?
jeroldow is offline   Reply With Quote
Old Dec 20, 2006, 5:25 PM   #7
Junior Member
 
Join Date: Dec 2006
Posts: 1
Default

Hi I'm new and this is my first post. I'm hoping someone here can please either help or advise me...

I just bought thissame Innovage Mini Digitalcamera at Walgreens for $10. :roll:I followed the instructions enclosed perfectly. First I installed the software, then I attached the USB cable and just as I was about to attach the camera to the USB cable my monitor and all my (video feed) went dead.

I have 2 computers attached to this samemonitor and I know the monitor itself works as I am using it right now to type this on the other computer. Does anyone have any ideas what this [email protected] camera and/or it's software could have done to the video feed from my computer system? I've restarted my computer 3 times to no avail. Nothing will show on my screen or else I'd uninstall the camera's softwareand system restore my computer...

(Dumb little garbage camera...grrr...):evil:



TIA for ANY help!!
Shannon1973 is offline   Reply With Quote
Old Dec 24, 2006, 9:14 AM   #8
Junior Member
 
Join Date: Nov 2006
Posts: 5
Default

Although I returned my innovage after experiencing nothing but problems, my cousin bought one , loaded the software, took 20 stills, downloaded them, viewed them and was very happy. She did not know how to take motion shots so I set the camera to video mode and took 20 seconds worth. ( That's all the memory the digicam has if you first delete all stills from the camera) The first attempt played back just fine on her PC. However, the color quality in video mode leaves allot to be desired. We shot another 20 seconds worth, plugged the digi into her PC and attempted to play it back. Her PC shut down immediately and went to the safe restart mode screen. After 4 attempts to restart her PC we gave up. The PC seems to be locked into a crash and restart loop. She sent it in to the local PC repair shop and has a $100.00 estimate to repair it. I'll post what the shop says is the cause and what they did to repair it when it is up and running again. By the way, my cousin stepped outside after the problem started and played hand ball with the camera on the side of her brick garage. I volunteered to sweep up the 20 or so pieces after:|words. I wish I had that on video!!!
vondansand is offline   Reply With Quote
Old Dec 25, 2006, 5:24 PM   #9
Junior Member
 
Join Date: Dec 2006
Posts: 2
Default

My camera came with the CD with driver and software, but the driver software is giving me problems. First, I got a message the driver failed when I was preparing to download the photos. Then, I unplugged the camera and plugged it back in and got the Windows "Found New Hardware" wizard, but I got the same message as an earlier poster--advising me to terminate the installation--so I closed it out and uninstalled the driver hardware. After reading some of the problems that others on here have had, I'm not sure I want to risk installing it again! I guess you can't expect too much when you buy a digital camera at Walgreen's for $10! :sad:
subguy3 is offline   Reply With Quote
Old Dec 25, 2006, 8:51 PM   #10
Junior Member
 
Join Date: Dec 2006
Posts: 2
Default

Well, I finally gave up. I am taking all ten that I purchased for fun little gifts back to Walgreens and Rite Aid.

Thanks everyone for posting, trying to help...
loripowell is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:03 PM.