Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Panasonic / Leica (https://forums.steves-digicams.com/panasonic-leica-29/)
-   -   "System Error" for FZ10 (https://forums.steves-digicams.com/panasonic-leica-29/system-error-fz10-40910/)

Stuckey Dec 22, 2004 5:11 AM

I have a Lumix FZ10, that has worked perfectly since April this year. Today, after turning it on, the lens refused to retract when I turned it off. In addition, it now says "System error" on the LCD screen, and I am not able to do anything at all with the camera. The battery is fully charged, and there is no problem with the SD card (I've tried several SD cards, but same error). My camera is pretty much useless at the moment. The lens is still extended, and I can hear a "whirr" sound when I turn it on, but I cannot see any physical movement of the lens. It has not been impacted or dropped. What can I do? I bought it from an online store, which claims to offer a 1 year warranty on the camera, but I'm not sure what the issues are in regards to having it repaired by Panasonic, if in fact it does need to be sent/taken in for repairs. Thanks for any help! :)

I'm in Australia, BTW.

genece Dec 22, 2004 8:26 AM

I saw somewhere that someone twisted the barrel as they shut down the camera and the lens retracted.

Stuckey Dec 23, 2004 7:32 AM

I have tried to gently pressure the lens into retracting while turning the camera on and off, but it will not budge. I have resigned myself to the fact that I'll just have to bring it in somewhere for repair :( Lord knows how long that would take!!

Thanks for your help :)

digcamfan Dec 23, 2004 11:08 AM

How long have you had it?

Hopefully, it is still under warranty!


All times are GMT -5. The time now is 8:48 PM.