Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Panasonic / Leica (https://forums.steves-digicams.com/panasonic-leica-29/)
-   -   Where have these springs come from? Lumix sensor clean gone wrong! (https://forums.steves-digicams.com/panasonic-leica-29/where-have-these-springs-come-lumix-sensor-clean-gone-wrong-215688/)

pjohnc Oct 26, 2015 5:35 PM

Where have these springs come from? Lumix sensor clean gone wrong!
 
Hi All,
I have been trying to clean the sensor on my wife's Lumix DMC-SZ3. I followed non-model-specific Lumix YouTube instructions and got to the sensor quite easily. But when I directed a puff of air between the sensor and the back of the lens a small coil spring popped out from somewhere, and I cannot for the life of me see where it has come from! This did not happen on the YouTube vids!! Later I spotted another identical spring on my work surface nearby.
Now, it is not uncommon for my repair attempts to result in the odd piece left over, but this seems serious because I can no longer power the camera on!
If anyone here can help me with this I should be exceedingly grateful. Meanwhile I will take it apart again and try to work it out for myself.

Regards, pjohnc

pjohnc Oct 26, 2015 6:54 PM

Trouble yourselves no longer, my friends. I believe I have located the home for these springs, between the sensor and the lens unit, but the camera is still dead. I guess I owe my beloved a replacement!


All times are GMT -5. The time now is 6:38 PM.