Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Jan 2, 2007, 1:19 PM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

Hi there

I've got a Panasonic FZ7. My wife and I were at a wedding on saturday and at the beginning it seemed that the flash was a little dimmer than it should be. Later, just after the service, the flash died. When looking direct in to the flash when you take a picture, it just manages a very dim 'fizzle', and doesn't muster enough light to be noticable unless you look at it.

Does anyone know what this might be, and how I could fix it? Or has anyone experienced this before?

Thanks
Ross
rossbeavis is offline   Reply With Quote
Sponsored Links
Old Jan 2, 2007, 4:14 PM   #2
Senior Member
 
bmccoy's Avatar
 
Join Date: Dec 2004
Posts: 362
Default

Ross,

Sorry to hear about the flash issue. From your description it does sound like a malfunction. Just to be sure take it into a completely dark room and take a pic. If the flash does not work properly with it set to auto mode then it must be dead. Contact the reseller for help but unless it's really new you will probably end up working with Panasonic. Don't delay, every day you wait gets you one day closer to the end of warranty.

Hope you get it fixed real soon.

-Brett
bmccoy is offline   Reply With Quote
Old Jan 2, 2007, 8:28 PM   #3
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

Bummer, that was my worst fear. I've just checked it on Auto in a darkened room. Nothing but a pathetic flicker!

Does anyone know the support contact for warranty repairs in the UK? I bought it from PC World (I know, I know - they were the cheapest, believe it or not!) and had a problem a while ago (that subsequently went away) and they just gave me a sheet with a 3rd party's details on it.

Thanks
Ross
rossbeavis is offline   Reply With Quote
Old Jan 2, 2007, 9:31 PM   #4
Senior Member
 
genece's Avatar
 
Join Date: Jun 2003
Posts: 2,111
Default

While I may be grasping at straws......do a complete factory reset to restore the Factory defaults.......if that fails remove the battery at least overnight perhaps longer.

Are you aware of the Force Flash off setting.....I am not sure if the FZ7 has that feature or how it acts if its forced off.......Also your ISO could not have got shoved up to 1600 has it.
genece is offline   Reply With Quote
Old Jan 3, 2007, 4:09 AM   #5
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

Do you know how I do a complete factory reset? I have tried leaving the battery out overnight but this seemed to have no effect on the camera - it didn't even seem to lose any settings.

I don't know anything about a force flash off setting. If I want the flash off when I take a photo, I just push it down!

Thanks for your help - again, any info on the UK repair centre for Panasonic would be great!

Ross
rossbeavis is offline   Reply With Quote
Old Jan 5, 2007, 12:42 AM   #6
Junior Member
 
Join Date: Mar 2006
Posts: 3
Default

Reset is located on screen 3 of setup menu. The REC or SETUP menu settings are reset to the initial settings.
djetton is offline   Reply With Quote
Old Jan 5, 2007, 10:28 AM   #7
Junior Member
 
f1charlie's Avatar
 
Join Date: Jun 2006
Posts: 8
Default

Find your nearest service centre here:

http://www.panasonic.co.uk/customer-...er-locator.asp
f1charlie is offline   Reply With Quote
Old Jan 6, 2007, 1:25 PM   #8
Senior Member
 
Join Date: Jan 2005
Posts: 193
Default

I might suspect the battery. If you have a spare battery, which you should, then try using it.
shutter_bug is offline   Reply With Quote
Old Jan 6, 2007, 2:20 PM   #9
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

We have two batteries and the flash works with neither of them. I haven't tried the reset yet but will give it a go somepoint.

Thanks for the link to the service centres, Charlie.

Ross
rossbeavis is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:02 AM.