Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Jan 28, 2007, 9:24 PM   #1
Senior Member
 
squirl033's Avatar
 
Join Date: Dec 2004
Posts: 6,719
Default

well, i finally sent my FZ20 off for repair. it had gotten something messed up in its little brain, and refused to take exposures longer than 1 second in "P" mode, which is a problem for night shots. i could still use it in A or S modes okay, but i figured hey, it's not per spec, and ipaid extra forthe warranty, might as well get my money's worth... hopefully it'll be a simple replacement of firmware or a circuit board, and my trusty FZ will be back to me good as new before the weather gets nice and i need it for those spring sunsets!!




squirl033 is offline   Reply With Quote
Sponsored Links
Old Jan 28, 2007, 9:49 PM   #2
Senior Member
 
bayourebel's Avatar
 
Join Date: Jan 2006
Posts: 2,561
Default

Glad to hear that in time you will be back posting those wonderful photos, Rocky. I know you love the Cannon, but we also miss you on the forum.
bayourebel is offline   Reply With Quote
Old Jan 28, 2007, 9:51 PM   #3
Senior Member
 
annie57's Avatar
 
Join Date: May 2006
Posts: 1,613
Default

gerry's words are so well said and I can't say it any better than he does!!! Please don't leave us!!!!!!!!!!
annie57 is offline   Reply With Quote
Old Jan 28, 2007, 10:58 PM   #4
Senior Member
 
squirl033's Avatar
 
Join Date: Dec 2004
Posts: 6,719
Default

no worries, Annie... i'll be around!
squirl033 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:50 AM.