Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old May 4, 2012, 10:08 PM   #1
Senior Member
 
happy_peasant's Avatar
 
Join Date: May 2006
Posts: 2,048
Default FZ150 Problem

The wife and I are taking a trip of a few days to look at shorebirds, butterflies and dragonflies. I brought both the FZ150 and the FZ35. And the FZ150 is giving me some problems. It iwll work fine, and then decide to freeze up, and the zoom, wheel, shutter, and menu button area will stop working. I have to turn it off and on, spin dials, curse, and eventually it starts working. Maybe for a long time, maybe just for a moment. I suspect the software has gone bad or something, and will have to send it inn for repair. Big pain. I am glad I did not wait until the FZ35 died to buy this so I will still have a working camera when I send it in.
Steve
__________________
FZ7 and FZ35 - Deceased, FZ18 - Given daughter, FZ150, E-PL1 and G3 - In use.
happy_peasant is offline   Reply With Quote
Sponsored Links
Old May 5, 2012, 1:20 AM   #2
Senior Member
 
catalex54's Avatar
 
Join Date: May 2011
Location: Near Venice in Italy
Posts: 2,454
Default

I'm sorry Steve, I hope that the assistance in your country is as fast as in Italy, in a week have done the repair of my FZ45 under warranty!
Keep us updated!
__________________
DMC-FZ150 & Hoya HD UV Filter + DMC-FZ45 & Hoya HMC UV(C) Filter - Macro & Tele Kit (DMW-LC55 + DMW-LT55 + DMW-LA5) - Benro A-197EX + HD-18 & Manfrotto MKC3-H01 Tripods & MMC3-02 + 234RC Monopod
Alex
catalex54 is offline   Reply With Quote
Old May 5, 2012, 4:23 AM   #3
Senior Member
 
Join Date: Apr 2010
Posts: 1,130
Default

I had a similar problem with my FZ40. Pulling the battery out was the only thing that would fix it.
__________________
Disclaimer: I take photos of life rather than live to take photos and my opinions of cameras are reflected accordingly.
FiveO is offline   Reply With Quote
Old May 5, 2012, 8:49 AM   #4
Senior Member
 
happy_peasant's Avatar
 
Join Date: May 2006
Posts: 2,048
Default

Thanks Alex and FiveO. I did take the battery out a time or two and could not see that it made a difference. Just strange stuff.
__________________
FZ7 and FZ35 - Deceased, FZ18 - Given daughter, FZ150, E-PL1 and G3 - In use.
happy_peasant is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:46 AM.