Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Oct 28, 2013, 7:15 PM   #11
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,741
Default

It's interesting that whilst the FZ70's aperture at full zoom is "only" f/5.9- that of course is at the full 1200mm.... and one could argue that's not really that bad.
What would the aperture be wide open at say 300mm,600mm or 900mm...?
The biggest gripe I'd have about this camera is its "burst" performance, which frankly barely qualifies as a "burst".
Yes it can shoot at a pace of 2,5 and 9fps (the first two with continuous AF if you wish...)- but sadly the "burst" is a mere 3 frames only... equating to a 1/3rd of a second action at the fastest pace- and even dropping to 5fps still only gives you 3 frames..

I guess they didn't want to tread on the toes of the FZ200 too much...!

Here's what the boys at Cameralabs think... with some sample images/comparisons...
http://www.cameralabs.com/reviews/Pa...DMC_FZ70_FZ72/
SIMON40 is offline   Reply With Quote
Old Nov 12, 2013, 7:32 PM   #12
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

I'm still hoping to purchase the FZ70 in the next few weeks.
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Nov 24, 2013, 11:19 AM   #13
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

Well, I'm placing my order for the FZ70 next week, along with a Tiffen 55mm UV filter, and a Lexar 16GB Class 10 Pro memory card.

Is this UV filter one you would recommend? I simply want it for protecting the lens.
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Nov 24, 2013, 3:34 PM   #14
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day Carol

Nothing wrong with Tiffen filters
my only thought is to watch out for stray lights when out at night ... my camera + UV filter picks up sparkles from street lights at 45 deg to the lens axis

Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Nov 24, 2013, 6:29 PM   #15
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

Phil, thanks for that night time tip, I appreciate it!
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Nov 26, 2013, 4:53 PM   #16
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

Well, I have the FZ70 in my possession!!! I won't be using it until Christmas. I had planned to order it online for $333; and today found it in my local Target store for $349!!

Stay tuned Christmas for the first pictures from the FZ70! I'm really excited!
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Nov 27, 2013, 1:42 PM   #17
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

I'm charging the battery, to check the camera out to make sure it's ok, then putting it away until Santa comes.

Thought you might like to see the FZ40 side by side with the FZ70!
Attached Images
 
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Nov 27, 2013, 1:45 PM   #18
Senior Member
 
jjdog2's Avatar
 
Join Date: Feb 2011
Location: Southeastern Ohio
Posts: 6,384
Default

Have fun Carol.
__________________
Comments and suggestions for improvement welcome and appreciated.
jjdog2 is offline   Reply With Quote
Old Nov 27, 2013, 4:54 PM   #19
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

I charged the battery to make sure the camera was operating; then back in the box. It will be most difficult now waiting for Christmas!
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
Old Dec 5, 2013, 2:28 PM   #20
csa
Senior Member
 
csa's Avatar
 
Join Date: Dec 2010
Location: Montana
Posts: 1,539
Default

Well, I couldn't contain myself & took a couple of photos. They were completely "washed" out, and the adjustment for brightness didn't work. I fiddled all day, thinking I was missing something on how to adjust it; but gave up and returned it the next day, for another. The 2nd one's brightness adjustment worked just fine, so the original FZ70 was indeed faulty. So glad I did go ahead & check it out more!
__________________
Carol

~Pentax K10D~
~FZ40~
csa is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:50 PM.