Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Dec 8, 2013, 6:49 AM   #1
Senior Member
 
deadshot's Avatar
 
Join Date: Apr 2006
Location: Hertfordshire UK
Posts: 759
Default FZ 200 Dust ?

Ok now I have your attention :-)
Due to the earlier post "big gripe about Panasonic" I'm curious to know how many if any of you FZ200 owners have had a dust problem and what you did about it .
Many thanks
__________________
D5100 +18-200mVR Nikkor lens.
SB400 Flash, ML-L3 Remote.
SB 700 Flash
Holster + Shoulder Bag.
Beike carbon 4 section tripod/monopod
Gorillapod SLR Zoom + BH1 ball head
Panasonic FZ1000
Panasonic FZ200
Nissin D i40 Flash
+ SLR Gorillapod
deadshot is offline   Reply With Quote
Sponsored Links
Old Dec 8, 2013, 3:29 PM   #2
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day DS

Can't comment on the FZ200 as I don't have one
But in the household over the past 10 years we've had / got now ..

FZ7 ..... never showed any dust issues
FZ28 ... ditto
FZ30 ... ditto
FZ35 ... ditto
FZ100 . ditto

Fuji S5000 ... ditto
Fuji X-s1 ...... ditto

Panny G2 ... sometimes
Pentax Kx .. h-u-g-e / constant dust issues

Does this help at all?
Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Dec 8, 2013, 7:24 PM   #3
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,741
Default

FZ's with dust..?
My history...
FZ7,FZ20,FZ150- all fine...
In fact,I don't recall any of my bridge/superzooms with a dust issue... and I've had too many to list...lol...

I'd be very surprised if there was an FZ200 out there with such a problem...
SIMON40 is offline   Reply With Quote
Old Dec 9, 2013, 9:39 AM   #4
Senior Member
 
deadshot's Avatar
 
Join Date: Apr 2006
Location: Hertfordshire UK
Posts: 759
Default

I've just googled it and appears that there are some posts on dpreview where the FZ200 has got dust on the sensor.It doesn't seem to be a general problem though.
Thanks for the replies
__________________
D5100 +18-200mVR Nikkor lens.
SB400 Flash, ML-L3 Remote.
SB 700 Flash
Holster + Shoulder Bag.
Beike carbon 4 section tripod/monopod
Gorillapod SLR Zoom + BH1 ball head
Panasonic FZ1000
Panasonic FZ200
Nissin D i40 Flash
+ SLR Gorillapod
deadshot is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:47 PM.