Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Mar 17, 2005, 6:12 PM   #1
Junior Member
 
Join Date: Mar 2005
Posts: 12
Default

II recently purchased the FZ20 and purchased a "kit" offered by the seller which included odds and ends (on hindsight, probably not the way to go). The extra battery I received is a CGR-S002.... It fits, and it does work, yet it doesnt work in the charger which came with the camera. My question is, should I continue to use the model battery for an extended time?
scrap is offline   Reply With Quote
Sponsored Links
Old Mar 18, 2005, 1:28 AM   #2
Senior Member
 
squirl033's Avatar
 
Join Date: Dec 2004
Posts: 6,719
Default

i'd play it safe and pick up a couple of CGA-S002's. you can get them cheap enough on ebay that it's inexpensive insurance, and they will work with the charger...
squirl033 is offline   Reply With Quote
Old Mar 18, 2005, 7:08 AM   #3
Junior Member
 
Join Date: Mar 2005
Posts: 12
Default

squirl033 wrote:
Quote:
i'd play it safe and pick up a couple of CGA-S002's. you can get them cheap enough on ebay that it's inexpensive insurance, and they will work with the charger...
Excellent... takin trip to Hawaii soon and I sure wouldn't want the battery to pick that time to decide not to work anymore. Thanks.




scrap is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:40 AM.