Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Sep 7, 2005, 10:29 AM   #1
Junior Member
 
Join Date: Feb 2005
Posts: 9
Default

My FZ15 has recently started to lock up randomly. I will be in the midst of takingphotos and the zoom, shutter, & any of the buttonsstop responding.

If I turn it off and back on it sometimes works, other times I need to remove the battery, sometimes that doesn't even fix it and I just put it down for a while.When I gointo the mode to review photos, it continously cycles through the delete photos menu (luckily it does not delete anthing) but the buttons don't respond.

Has anyone experienced this type of issue? I thinkI am still covered by the parts warranty but I have no clue what to expect of the labor cost. Until I get this figured out the camera is basically useless because I can't count on it working.

thanks for any help!
kjo43 is offline   Reply With Quote
Sponsored Links
Old Sep 11, 2005, 6:07 PM   #2
Junior Member
 
Join Date: Feb 2005
Posts: 9
Default

bump.... anyone?
kjo43 is offline   Reply With Quote
Old Sep 12, 2005, 12:23 AM   #3
Senior Member
 
Charlie46227's Avatar
 
Join Date: Nov 2003
Posts: 295
Default

I've not experienced this, but my only suggestion would be to try a completely new battery. If possible, you might do so in a local camera store. It is possible that the battery is just not getting consistent power to the camera.

It didn't accidentally get wet for even a short period of time did it?
Charlie46227 is offline   Reply With Quote
Old Sep 12, 2005, 7:48 AM   #4
Senior Member
 
genece's Avatar
 
Join Date: Jun 2003
Posts: 2,111
Default

Anything gettig hot (the battery or card) ?

You could tryremoving the battery overnight.

But I would get a hold of Panasonic... someone reported a FZ15 that Panasonic could not repair so they sent him a FZ30.
genece is offline   Reply With Quote
Old Sep 12, 2005, 8:42 AM   #5
Junior Member
 
Join Date: Feb 2005
Posts: 9
Default

thanks for the ideas, I'll give them a try... otherwize its definetley going back to panasonic for repair. Was really just hoping somone had seen this so I could have an estimate of cost, anything much over $100-150(labor)and I think I'll just look for a new camera.

the camera spends alot of time in my boat (fresh water), but can't say its ever been wet, but I suppose some type corrosion could account for the random behavior.
kjo43 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:53 PM.