Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Panasonic / Leica

Reply
 
Thread Tools Search this Thread
Old Oct 3, 2005, 3:15 AM   #1
Member
 
Join Date: Oct 2004
Posts: 98
Default

Hi Everybody

I need your help.

I just bought myself a starblitz flash unit for my panasonic FZ20. Im quite happy with the flash. It has a vertical and horizontal swivel and most importantly has a slave function.

However im having a few problems and im trying to understand the reason.

1. When i mount the flash on the hotshoe the camera reads the external flash and the aperture is a constant f2.8. this cant be changed and the shutter speed is a constant 1/60 except for Manual mode where it goes up to 1/250.

The settings and readings on the flash unit seem to be almost of no use as the aperture is set at constant. Is this a normal limtation in the camera. Any appropriate setting that one would suggest for using the flash.

2. While using the flash as slave i have a very strange problem. The pictures come darker (almost underexposed) than using only the pop up flash on the camera. The slave flash is used ata 45 degree angle from the subject (i normally shoot portraits.) and closer to the subject than the popup flash.

Is there any particular reason for this. Is there any way that slave flashes should be used for eg. angles / distances

I hope i have been able to explain my problem

I really need your help

Besties

Dyu




dyu_d is offline   Reply With Quote
Sponsored Links
Old Oct 3, 2005, 8:16 AM   #2
Senior Member
 
genece's Avatar
 
Join Date: Jun 2003
Posts: 2,111
Default

I do not know about that flash but if it were a sunpak you would set the flash to manual so you can adjust the camera aperture.

And not all flashes work as a slave with a digital camera as digital cameras use a series of preflashes that cause some slaves to fire early.

And slaveflashes that can work with a digital cameraneed to be taught when to flash. You will need to read the manual.

Maybe someone here has oneand can be of more help.
genece is offline   Reply With Quote
Old Oct 3, 2005, 9:52 AM   #3
Senior Member
 
tchuanye's Avatar
 
Join Date: Feb 2003
Posts: 1,279
Default

genece is right on the slave part. The preflash will cause these problems.

As to using the flash, here is a good site:

http://www.cs.mtu.edu/~shene/DigiCam/

Look under External flash
tchuanye is offline   Reply With Quote
Old Oct 3, 2005, 6:28 PM   #4
Junior Member
 
arrow's Avatar
 
Join Date: Nov 2004
Posts: 19
Default

dyu_d wrote:
Quote:
Hi Everybody

1. When i mount the flash on the hotshoe the camera reads the external flash and the aperture is a constant f2.8. this cant be changed and the shutter speed is a constant 1/60 except for Manual mode where it goes up to 1/250.

The settings and readings on the flash unit seem to be almost of no use as the aperture is set at constant. Is this a normal limtation in the camera. Any appropriate setting that one would suggest for using the flash.




Hi dyu_d

Setting the external flesh mode to manual instead of preset should permit you to vary the aperture in Aperture Priority mode to match the setting on your flash.

I agree with the others on the slave problem.

arrow
arrow is offline   Reply With Quote
Old Oct 3, 2005, 7:36 PM   #5
Senior Member
 
tiger98's Avatar
 
Join Date: Sep 2005
Posts: 2,696
Default

Hi dyu_d, Check pages 81 and 82 of your FZ20 manual. They address the correct settings etc for your external flash unit. Hope that helps !
tiger98 is offline   Reply With Quote
Old Oct 5, 2005, 10:56 AM   #6
Member
 
Join Date: Oct 2004
Posts: 98
Default

Hi

Thanks for your replies

Could anyone tell me how much a safe sync would cost. Cause from what i know my flash is high on voltage power. Any safe syncs recommended???


Also would it help if i bought a slave unit (the ones mounted on the horse shoe) to solve the underexposure problem when i use my flash as a slave.

I really depend on you guys for guidance and thanks a ton for providing me with the same


Besties

Dyu
dyu_d is offline   Reply With Quote
Old Oct 6, 2005, 6:42 PM   #7
Senior Member
 
wise's Avatar
 
Join Date: Nov 2004
Posts: 406
Default

Hi, dyu_d!

How did you decide to go for that particular flash. JJM at mumbai have VIVITAR 3200A, for INR1350. It doesn't have swivel function but can move vertically. I might go for that as most of the popular ones are either not available here or cost an arm and a leg.

BTW I still have your phone no. Might give you a ring , one of these days.:-)


wise is offline   Reply With Quote
Old Oct 6, 2005, 11:56 PM   #8
Member
 
Join Date: Oct 2004
Posts: 98
Default

Hi Wise

Nice to see you reply

Ok i was being not so wise when i went for the flash. Reasons i went for it

Swivel and Slave - I intend to do some product photography shots and can not invest in those huge lights. So i thought this may be helpful for lighting from different angles. However it seems to be more ofa bane than a boon right now.

The twin flash for portraits. Again one of the areas i want to speciallise in...



But now it looks like im stuck with this flash. May use if for one of my old film cameras that i just got repaired.

Will be awaiting your call

Besties

Dyu
dyu_d is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:44 AM.