Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Panasonic Micro Four Thirds

Reply
 
Thread Tools Search this Thread
Old Dec 25, 2012, 11:40 AM   #1
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default G3 with flash

First, Marry Christmas to all. Hope you're having a good time.

Now, I am so mad with my G3 and its inability to take proper pictures with flash that it's not even funny. I feel like smashing the stupid camera up. Last night at a friend's house I was unable to take more than a couple of decent shots because the G3 would not meter correctly every time flash was used. Even though the room was small, only the subjects real close to the camera would be lit and even that, the illumination was not proper. My ZS6 would have done a better job. Some people took much better pictures with their iPhones and ancient P&S. The other thing I noticed was that even though metering was way off (BTW, I experienced the same problem in the past with my old G1, so I think it's genetic), it was much worse with the 14mm or the new Sigma 30mm as opposed to the 14-45mm kit lens. I could perhaps understand the camera having a problem with a third-party lens but with one of its own bread? c'mon...

I tried shooting with different metering settings: matrix, center weight and spot; different modes: P, SCN (portrait, portrait in low light with flash, A, etc.; tried to lock exposure pointing the camera at darker area, a brighter area; I increased the flash output to the maximum, but nothing...NOTHING worked.

So, either I'm missing something or the G3 is just a piece of junk when it comes to taking pictures with flash. Any suggestions anyone?
__________________

Tullio
Tullio is offline   Reply With Quote
Sponsored Links
Old Dec 25, 2012, 6:49 PM   #2
Senior Member
 
Join Date: May 2012
Posts: 297
Default

Merry Christmas Tullio, I know how you feel.

I started to use the flash for macro with extension tubes and legacy primes on the G1 and found that in Manual mode the camera goes into a default with the flash open. The shutter speed is limited to 1/160 as the fastest.

Then set the ISO to 100 or 200, aperture to f/5.6 and use the flash exposure to increase or decrease the brightness. As I widen or narrow the aperture, I can increase or decrease the flash exposure by the same amount and it will be accurate. Most of the time I have to use the flash white balance.

After getting accustomed to that procedure, I started to get good results using the legacy primes alone.

Now I do better in the auto modes because it taught me "something". I think it has more to do with the shutter speed than anything else. If any auto feature is active like ISO or aperture that can affect the shutter speed, the flash can have the opposite effect of the exposure.

It gets confusing using the legacy primes with the 1/3 stops flash exposure as mine have either full stops or 1/2 stops. If you do test using the legacy primes, keep that in mind. Full stops for testing will make more sense.

I'm not sure what I learned, but now I can light up another room through a doorway in near total darkness from about 25 feet/ 8 meters away.

I can do it with the 14-45 now, but it was the legacy primes and extension tubes that taught me how.

Try keeping the ISO limited to 100 to 400 and the shutter speed at 160th or slower and everything should work.

From the comments I've seen, the Panasonic flash is a real PITA. Most people struggle with it. Now that I've figured it out, I kinda' like it. But you sure can't take it for granted.

It works really nice with my homemade and Cowboy Studios diffusers added, but they aren't a quick fix if you can't get it working in the first place.

If you can describe a situation, I can try mimicking that with the G1 and 14-45. Then transfer my settings and see if that get's you a starting point for reference. I had no luck whatsoever until I started doing the macro and then the flash made sense.

Good Luck,

Les.
BBbuilder467 is offline   Reply With Quote
Old Dec 26, 2012, 11:12 AM   #3
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

Thanks very much for the info., Les.

I think I would be more understanding if I was using legacy lenses because they don't communicate with the camera electronically. Yes, I had the camera set to AUTO ISO and flash set to AUTO (I tried S and forced flash as well but nothing made the camera perform any better). The situation I was in was ordinary. Group gathering in a family room around a coffee table. Even though the room was large, everyone was sitting close together and I was no more than about 5-8 feet from the object. The best results I obtained was when I had the camera metering set to spot. Then I pointed to a dark area and locked the exposure. I think that fulled the camera and the image was brighter. However, I missed a lot of special moments because I had to fiddle with the beast. As I said, my P&S performs 100 times better. The other problem is the skin tone. It has this reddish cast, which makes people look very unattractive. I tried setting the camera to both AWB and flash but the results were pretty much identical.

I will try your technique at New Years but I'll also make sure I have my P&S with me as well. I'll report back. Cheers.
__________________

Tullio
Tullio is offline   Reply With Quote
Old Dec 27, 2012, 10:58 AM   #4
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

I did some research and apparently my experience wide spread. I came across several posts on the subject. The suggestions go all over the place but I tried a few that actually work (to a certain extent). They are:

Set the ISO to 600 (actually 640 on the G3)
Shoot in S mode setting the shutter speed to 1/60
Set WB to daylight to reduce reddish skin tones
Increase flash output to+1

I took a few shots with this setting and noticed improvements in skin tone and brightness. We'll see how it goes this coming w/e.

I fail to understand why Panasonic cameras such as the ZS6 and LX5 manage to produce good quality pictures taken in P mode with flash and WB set to AUTO but not the G3. One would think that the engine would perform similarly on any body. I just don't get it.
__________________

Tullio
Tullio is offline   Reply With Quote
Old Dec 29, 2012, 4:41 AM   #5
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default

Modern DSLR and mirrorless cameras ought to be better than legacy cameras we used to have because they are assisted by computers inside the camera. After I went digital, I found that taking flash pictures is more difficult and often don't get the results I expected. I have given up on using the automatic setting and go strictly manual with my external flash. It is a little awkward in the beginning but I am getting used to it. The bad experience is the same with Canon, Samsung and Olympus. My old Sony A200 is a little better than the other three in flash applications.

My friends who use Nikon DSLRs seem to get good results just using the automatic settings. It makes me envy as hell.
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Dec 29, 2012, 12:27 PM   #6
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

I had many DSLRs: Nikon D40, Pentax K100, Sony A200/A300, Olympus E510/520 and eventually I standardized on m4/3 for its compactness w/o having to compromise IQ too much. Even though I agree that flash photography with digital cameras using the built in flash is not nearly as consistent as it was with old SLR+external flash, I do find these cameras to produce much more consistent results with their built-in flash than the m4/3 G1/G3/EPL1.
__________________

Tullio
Tullio is offline   Reply With Quote
Old Dec 30, 2012, 1:20 AM   #7
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default

Thanks Les and Tullio! I learn a lot about flash application on the Lumix G3. It gives me enough confidence to buy one. I 'd just ordered one from B&H for $299 with the 14-42mm kit lens.
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Dec 30, 2012, 2:13 PM   #8
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

You'll like the G3. As a first recommendation, if you like sharp images OOC, I suggest you set Sharpness to +2 and iResolution to Extended. I keep iDynamic to Standard and prefer to shoot in Natural with Saturation and Contrast set to +2. It seems like I get a better DR.
__________________

Tullio
Tullio is offline   Reply With Quote
Old Dec 30, 2012, 2:22 PM   #9
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default

Quote:
Originally Posted by Tullio View Post
You'll like the G3. As a first recommendation, if you like sharp images OOC, I suggest you set Sharpness to +2 and iResolution to Extended. I keep iDynamic to Standard and prefer to shoot in Natural with Saturation and Contrast set to +2. It seems like I get a better DR.
Thanks! I will remember the settings. Good advices as always!
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Jan 4, 2013, 2:37 AM   #10
Senior Member
 
Join Date: May 2012
Posts: 297
Default

Well, Tullio & WCKSer, Happy New Year.

How did you make out?

I took a couple hundred test shots using the onboard flash and just kept coming back to my baseline set-up in the manual mode. The other modes would work within a certain perimeter, then went haywire.

I set ISO 100, 1/125th shutter speed, picked an aperture and then just used the flash exposure to adjust. I had to go back to standard film mode with "no" +/- or the color was way off. I tried all the white balance settings including varying from 4200-5500 in Kelvin and what worked most consistently was the flash white balance with a fine adjustment 2 steps toward green & amber. All the shots looked "natural".

I tested in strong lighting and near total darkness and the shots looked the same. I don't think the camera had any idea what the lighting actually was. It just exposed according to the flash.

The meter even read 3 stops underexposed and that would come up on the review display, but the shot was exposed like I set the flash.

It seemed to work the same way with the slr manual primes or the 14-45.

The biggest problem I have is matching the white balance. Outdoors I'm always trying to enhance the colors, where here I'm trying to get the more natural/neutral look. Adjusting the color in the white balance seems to do it. 3 steps is obvious, 2 steps noticeable, and 1 step is subtle. I usually go 2 steps.

I bracket white balance a lot outdoors, so I can recognize the difference more easily than most folks normally would.

I don't have any faces to work with, but I was able to match the various woodgrains and the biscuit and white of my Samoyed. That's been the hardest thing for me to do with or without flash.

I've noticed that too. My dogs and cats don't pay any attention to this flash. They'll sit and stare right at it over and over again. Anything else I've used and one flash and they were gone. They act like they don't even see it. They don't like the focus assist light, but they totally ignore the flash.
BBbuilder467 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:39 AM.