Steve's Digicams Forums

Steve's Digicams Forums (
-   Pentax (
-   -   Pentax Optio S (

Kalle Apr 28, 2005 2:55 AM


My camera suddenly gives this error A90.

When I turn on and off the camera several time could mayby take som picutres.

It seems that it is not only me who has this problem. And it seems that this is developing problem of Pentax cameras. And I hope that Pentax factory gives a firmware to fix our cameras and don´t try to earn money based on this factory fail.

It is a obvios service and advertising they can give unlocky costumers.

Is there anyone who could fix this problem without sending the camera to Pentax service?

ikm May 4, 2005 11:15 AM

Kalle, I'm having the same problem. Did you ever find a fix???


stelt Jul 25, 2005 4:37 AM


I found a fwdc110p.bin /pentax optio S firmware may be/ but already not work.

1. copy fwdc110p.bin to sd card.

2. hold menu and press power on

I see only soft ver.

help me please.

snoopy Aug 29, 2005 2:23 PM


I've got the same problem - just right after 2 years when all warranty is void :-(
Is nobody out there that has a solution other than sending the camera in?
I think there must be some kind of hard factory reset, but I couldn't find any information about this. Hope that I can revive my expensive toy...


mounty Sep 3, 2005 2:27 PM

:mad:Hi Kalle, i have the same problem. Just right after 2 years when all warranty is void it shows A90:?. I sent it to Pentax in Hamburg and they offered to repair it for ~160€. Now I have it back and am looking for a solution. Hope somebody knows how to repair the software. I think it is a software problem.

RETrACE Sep 5, 2005 1:02 PM

Same probleme here :(
A90 is displayed when i power on the camera.
If i want to update the firmware by loading
Fwdc130p.bin (power+menu button)
after about 10 seconds i get:
Error !
and thats it...
Can anyone help me ?

philter Sep 5, 2005 8:49 PM

I think the fwdc130p.bin file is for the Optio S5i Camera.
If you have the Optio S camera, then use the file fwdc110p.bin

I have a Pentax Optio S digi-cam and just today I am now receiving A90 error message.

How do I go on about fixing this? Please please do tell!!

I located a German version of the file fwdc110p.bin, and I placed it into the Root directory of my SD Card (which is formatted to FAT). Then I insert the card and press press Menu+ON together.

Then all it does is display "VER 1.00", then the back light turns off, then back on and then it displays the "A90" error message.

Any Help would be MUCH APPRECIATED!!!


ps) If anyone else has a copy of the file fwdc110p.bin (pref. in English) I would love a copy! Maybe the German Version I have is not compatible, or incorrect CheckSum, etc. etc. I would really like to try the English version.

Thanks Again!

RETrACE Sep 6, 2005 6:44 AM

I forgot to mention that i have Pentax Optio S5i, so thats why i'm using Fwdc130p.bin.
I dont know what to do anymore....
If i want to update the firmware, i get the "Now loading" message and after a while...
and that's it.
Come on guys !!!
What we are going to do with our digital cameras ????

philter Sep 6, 2005 6:39 PM


My Optio S is now working!

I loaded the flash file onto my SD CARD, tried to do Menu+ON, and received "Error" like yourself.

So I thought.. Hmmm normally one must plug a device into the wall (ac/adapter) if one were to flash the firmware. Kuz if the battery were to die in the middle of erasing the prom, that would not be FUN!

So what I did was charge my battery to FULL, then right away I followed the steps to burn the new copy of the firmware (Menu+ON), and TaDa.. It worked!

After Burning it said Complete, then I restarted and it powered up and the lens retracted out.

One thing I did do in my playing-around was I went into the Secret Menu (The Secret Menu was still working even though I was getting A90), and I played around with some of the Erase/Write/Test/Format options in the Rom Update Menu. I don't know if this led to my successful prom burning, or if it was the full battery.

Anyway I hope you all will be successful as I was.

If not, I will be more than happy to take your dead cameras and give it a try myself.
Best of Luck,

RETrACE Sep 7, 2005 3:55 AM

>> Philter
I already did what you said, to recharge the battery to the full.
I put the .bin to my sd card but i still receive the "Error"
message after about 10 seconds.

I dont have a AC adapter on my camera.
I charge with another charger my battery.
Do you think this is the problem?
If that's the problem, it's a serious problem, because i can't find a AC adapter. (I'm from Romania)
Note: I have the OPTIO S5i
10x anyways !

All times are GMT -5. The time now is 10:28 AM.