Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Reply
 
Thread Tools Search this Thread
Old Jul 3, 2007, 4:25 PM   #1
Member
 
Join Date: Mar 2007
Posts: 73
Default

Hi,
Back in high school I had a chinon and remember it had a Pentax mount.
That was a log time ago. Anyone know if Chinon is respectable, or should I just avoid them.

thanks
Bob
BobTheNailer is offline   Reply With Quote
Sponsored Links
Old Jul 3, 2007, 7:22 PM   #2
Senior Member
 
bilybianca's Avatar
 
Join Date: Nov 2005
Location: Hassleholm, Sweden
Posts: 3,435
Default

I have a Chinon 50 mm f1.7, and I had a Chinon 50 mm 1.9. Both work just fine on my *istDS, no problem at all. AFAK this should be the case with any Chinon lens, and all other K-mount lenses except some Ricoh- and Richo/Pentax bayonet lenses.

Kjell
bilybianca is offline   Reply With Quote
Old Jul 4, 2007, 4:39 AM   #3
Senior Member
 
jachol's Avatar
 
Join Date: Aug 2006
Location: NW. England
Posts: 1,201
Default

BobTheNailer wrote:
Quote:
Hi,
Back in high school I had a chinon and remember it had a Pentax mount.
That was a log time ago. Anyone know if Chinon is respectable, or should I just avoid them.

thanks
Bob
I have 3 Chinon lenses

1. 135mm/f2.8 M42 Prime from my film camera days, great portrait lens on a Praktica super TL SLR

2. 50mm/f1.7 MC K fit, ... a few sample shots in this thread
http://forums.steves-digicams.com/fo...mp;forum_id=80

3. 75 - 200mm/f1:4.0~4.8 Zoom/Macro

The latter 2 were acquired since I got the K100D ... Over the years I've had several Chinon lenses, and always have had respectable results. ... My 2 cents worth ... Jack

Edit... I know some Chinon K mounts don't fit on a Pentax, but I believe they are easily modified, so that they do. I suspect that the zoom lens above has been modded. It fits no problem.
jachol is offline   Reply With Quote
Old Jul 6, 2007, 9:06 AM   #4
Member
 
Join Date: Mar 2007
Posts: 73
Default

HELP PLEASE ...

http://cgi.ebay.com/ws/eBayISAPI.dll...;rd=1&rd=1

won this lens, but I dont see how the aperture adjust... there is no ring. when I mount it on the k10d I get the f-- and can't seem to control the exposure. There is a m/a switch on the side and you can see the focus numbers on the picture, but thats it. Add stated auto focus but so far have had to do it by hand..oh and the mounting end of the lens has a bunch of brass contacts grouped together kinds like "00000" ANY HELP. Thanks

bob






BobTheNailer is offline   Reply With Quote
Old Jul 6, 2007, 9:48 AM   #5
Senior Member
 
jachol's Avatar
 
Join Date: Aug 2006
Location: NW. England
Posts: 1,201
Default

Bob, I hate to say this, but that looks as if it's an auto adjust lens, it looks non standard as regards the base contacts, how you get it to work I just don't know ... I've never seen one like that before. Perhaps someone else can shed some light. ... Jack

Edit... Just been checking those contacts are placed in a totally wrong position to the the usual ones on a pentax lens.
jachol is offline   Reply With Quote
Old Jul 6, 2007, 2:25 PM   #6
Senior Member
 
Join Date: Aug 2006
Location: Essex, UK
Posts: 1,868
Default

Search on Google reveals it fits a Chinon CP-9AF.



Those electrical contacts look strange there!



I wouldn't want to try that on my bodies.





Darren
Dal1970 is offline   Reply With Quote
Old Jul 6, 2007, 5:30 PM   #7
Member
 
Join Date: Mar 2007
Posts: 73
Default

nice :-(
Thanks for all the help
Guess I got stuck with a lemon. Oh well..I can actually get it to take a shot, but very over exposed and I can't dial it down.
BobTheNailer is offline   Reply With Quote
Old Jul 6, 2007, 8:23 PM   #8
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

BobTheNailer wrote:
Quote:
nice :-(
Thanks for all the help
Guess I got stuck with a lemon. Oh well..I can actually get it to take a shot, but very over exposed and I can't dial it down.
Use it in Aperture priority mode and let the camera set the shutter speed for you.
bigdawg is offline   Reply With Quote
Old Jul 7, 2007, 1:15 PM   #9
Member
 
Join Date: Mar 2007
Posts: 73
Default

Thanks. Tried that. It
seems to work but only in bright sunlight. indoors I can't seem to get focus conformation and have the camera allow me to take the shot. Weird. Maybe I can resell it. Any takers ???LOL. The out door shots are vary sharp.
BobTheNailer is offline   Reply With Quote
Old Jul 7, 2007, 2:21 PM   #10
Senior Member
 
robar's Avatar
 
Join Date: Mar 2005
Location: D/FW area Texas
Posts: 7,590
Default

bob,
i hate to say it but that looks like minolta mount

roy
robar is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:46 PM.