Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Reply
 
Thread Tools Search this Thread
Old Dec 23, 2007, 4:03 AM   #11
TC3
Senior Member
 
TC3's Avatar
 
Join Date: Jun 2004
Posts: 1,169
Default

I got the same lens in summer. I noticed the right side was a lot softer than the left side especialy in pics that were taken of subjects of 10 meters or more away at the wider end of the zoom. It was a big joke compared to my modest kit lens. I decided to return it and have been waiting for something else to replace the kit lens with.

Tony
TC3 is offline   Reply With Quote
Old Dec 23, 2007, 6:01 AM   #12
Senior Member
 
bahadir's Avatar
 
Join Date: Jan 2006
Location: Izmir, Turkey
Posts: 6,263
Default

The defect could not be more obvious than this one:!:

RegardingTony's experience and judging fromanother copy they sent me as replacement, this is a wide spread issueabout Sigma!

http://forums.steves-digicams.com/fo...mp;forum_id=94

As you can read in my next post above: ''Testing the Sigma 17-70; The rest of the story!'' I sent back the lens to the general distributor of Sigma in my country, skipping the dealer I bought from to prevent further loss of time! It took onlya few telephone conversations with the product development manager there who had really a professional mind, plus a few example shotsto hise-mail!

I believe your perfect sigma is awaiting you; )


bahadir is offline   Reply With Quote
Old Feb 21, 2008, 9:48 AM   #13
Junior Member
 
Join Date: Dec 2007
Posts: 26
Default

To follow up on this, Sigma sent me a replacement lens (different serial#) and it doesn't seem to have any issues. I'll reserve judgement until after my next vacation though, since I never noticed issues w/ the original one until after a vacation when I tried a variety of focal lengths and distances.

kenyee is offline   Reply With Quote
Old Feb 22, 2008, 6:47 PM   #14
Senior Member
 
bahadir's Avatar
 
Join Date: Jan 2006
Location: Izmir, Turkey
Posts: 6,263
Default

Would be delighted to see your examples : ) Hope you'll end up with asmuch satisfaction as myself after the replacement traffic!

Btw, I've justbought a 72mm slim polarising filter for that lens ; )

http://forums.steves-digicams.com/fo...mp;forum_id=80
bahadir is offline   Reply With Quote
Old Sep 17, 2008, 8:30 PM   #15
Junior Member
 
Join Date: Dec 2007
Posts: 26
Default

After a vacation, it looks like the replacement doesn't do that well at 19mm...still looks like it has slight decentering issue :-P

Shot at f/5.6. Left side seems fuzzier than right side.

What's annoying is it happens at specific focal length/focusing distance combos so it's really hard to know if there's an issue unless you take a lot of different combos..
Back to Sigma service...hopefully, 3rd time's the charm...

Attached Images
 
kenyee is offline   Reply With Quote
Old Oct 3, 2008, 4:42 PM   #16
Senior Member
 
bahadir's Avatar
 
Join Date: Jan 2006
Location: Izmir, Turkey
Posts: 6,263
Default



Oh, I've just noticed your reply! You must have received yourlensby now. Hopeyou've been satisfied with the test shots. Would be delighted to see them : )
bahadir is offline   Reply With Quote
Old Oct 13, 2008, 2:01 PM   #17
Junior Member
 
Join Date: Dec 2007
Posts: 26
Default

Just got it back late last week. Haven't tested it much yet because I was busy all weekend.

The repair report says "replaced: kept same serial#".
What in the world does this mean???? I should have put a marking on the lens to see if I got the same one back because I have no idea if they just fiddled w/ the serial# adhesive label and sent it back :?

kenyee is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:05 PM.