Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Reply
 
Thread Tools Search this Thread
Old Nov 6, 2010, 11:49 AM   #1
Junior Member
 
Join Date: Nov 2010
Posts: 2
Default Pentax 80-200 lens

Hi: I have a Pentax DL digital camera. I wish to use my old FA80-200 mm F4.7-5.6 lens on this camera. It installs well with the bannet base. But will not shoot. The book says it is compatiable. The 80-200 lens doesnt have the "A" setting on the aperture ring. But it says you can bypass this to make it shoot. WHAT setting do I use??? Sieg
siegls is offline   Reply With Quote
Sponsored Links
Old Nov 6, 2010, 7:11 PM   #2
Senior Member
 
John.Pattullo's Avatar
 
Join Date: Aug 2009
Location: Scotland
Posts: 613
Default

hmmm without getting my camera out i cant tell you exactly what its called but it should be in the custom functions section of the menu - if you have your cameras manual it will tell you exactly what our after
__________________
Flickr
PENTAX K-5 & PENTAX K-7
Pentax-DA 12-24mm f4 | Pentax-DA* 16-50mm f2.8 | Pentax-A 50mm f1.4 | Tamron 90mm f2.8 Macro | Pentax-DA* 60-250mm f4 | Sigma 150-500mm
Pentax Photo Gallery
John.Pattullo is offline   Reply With Quote
Old Nov 6, 2010, 9:15 PM   #3
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,056
Default

I'm confused. You say that it's an FA (which means auto focus/auto exposure) lens and yet it doesn't have an A setting on the aperture ring? I suspect that if it doesn't have an A setting, it's not an FA lens, it's probably a K or M lens. It will work with your camera - But first, make sure you've gone into the menu and changed the setting to allow the use of aperture rings (I don't have a DL and don't remember what exactly it's called on the DS/DL cameras). Default is no.

Then set the aperture on the lens, put the camera on "M" mode. Focus, then push the AE-L button, which will temporarily stop down the lens and let the camera meter, setting the shutter speed. Then shoot. Pushing the AE-L button to meter becomes second nature very quickly.
mtngal is offline   Reply With Quote
Old Nov 6, 2010, 9:39 PM   #4
Senior Member
 
snostorm's Avatar
 
Join Date: Jan 2004
Location: Chicago Suburb, IL, USA
Posts: 2,770
Default

Hi siegls,

Welcome to the forum!

IIRC Pentax only made an 80-200 f4.7-5.6 in the A, F, and FA variants, and all should have an "A" setting on the aperture ring. There's a little button on the ring that allows you to move it in and out of the "A" position.

If the shutter refuses to fire, it's probably because it's set to AF (Auto Focus) mode, and this requires a focus confirmation before it will allow the shutter to fire. If you switch to M (Manual Focus) mode, it will allow the shutter to fire regardless of focus cofirmation.

Scott
snostorm is offline   Reply With Quote
Old Nov 7, 2010, 9:26 AM   #5
Senior Member
 
NMRecording's Avatar
 
Join Date: Feb 2010
Location: Eastern Appalachains
Posts: 866
Default

i had this lens and used it just fine on k20, should work.

it is a good lens, produces great coloring. I found mine soft at 200 but sharp up to about 150
NMRecording is offline   Reply With Quote
Old Nov 7, 2010, 2:48 PM   #6
Junior Member
 
Join Date: Nov 2010
Posts: 2
Default

Quote:
Originally Posted by snostorm View Post
Hi siegls,

Welcome to the forum!

IIRC Pentax only made an 80-200 f4.7-5.6 in the A, F, and FA variants, and all should have an "A" setting on the aperture ring. There's a little button on the ring that allows you to move it in and out of the "A" position.

If the shutter refuses to fire, it's probably because it's set to AF (Auto Focus) mode, and this requires a focus confirmation before it will allow the shutter to fire. If you switch to M (Manual Focus) mode, it will allow the shutter to fire regardless of focus cofirmation.

Scott
Thanks it works now,Sieg
siegls is offline   Reply With Quote
Old Nov 7, 2010, 7:37 PM   #7
Senior Member
 
NMRecording's Avatar
 
Join Date: Feb 2010
Location: Eastern Appalachains
Posts: 866
Default

it does work in AF tho right? It should, I had the FA 80-200 and it auto focused and auto exposed perfectly
NMRecording is offline   Reply With Quote
Old Nov 25, 2010, 5:44 PM   #8
Senior Member
 
fofa's Avatar
 
Join Date: Oct 2005
Posts: 547
Default

My F70-210 auto focuses and auto exposures just fine on my K2000.
fofa is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:21 AM.