Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax Lenses

Reply
 
Thread Tools Search this Thread
Old Jan 13, 2013, 10:24 AM   #1
Senior Member
 
fofa's Avatar
 
Join Date: Oct 2005
Posts: 547
Default Rikenon lens

Bought a 50mm f1.4 A for my Pentax K2000

But it only turns partway and stops.
I'm guessing these two things sticking up might have something to do with it since non of my other lens have them.

So is there anything I can do to make this lens work with my K2000?
Attached Images
 
fofa is offline   Reply With Quote
Sponsored Links
Old Jan 14, 2013, 5:29 AM   #2
Senior Member
 
jachol's Avatar
 
Join Date: Aug 2006
Location: NW. England
Posts: 1,201
Default

Quote:
Originally Posted by fofa View Post
Bought a 50mm f1.4 A for my Pentax K2000

But it only turns partway and stops.
I'm guessing these two things sticking up might have something to do with it since non of my other lens have them.

So is there anything I can do to make this lens work with my K2000?
Hi,

You're quite correct, the bit that sticks up (Not the aperture control) is the problem. I had this hitch with a Chinon lens, and found the offending piece was screw mounted and could be removed (mounting screws replaced). The lens could then be mounted, and worked fine. Later I found info on the net info on cutting the offending piece down, and tried that, it worked fine.

Check out the section called "More on third party lenses" at bottom of this page ...

http://www.robertstech.com/vivitar.htm#compatibility

There are links there to sites that had the mod info, unfortunately they're not always accessible, as explained in that section. there doesn't seem to be any access at this time. Hope this is of some help. ... Jack

PS. Be careful mounting Rikenon lenses on a Pentax they can lock on and be difficult to remove, I've no personal experience of this, so can't give info. No doubt others can offer details. ... J

Last edited by jachol; Jan 14, 2013 at 5:33 AM.
jachol is offline   Reply With Quote
Old Jan 14, 2013, 3:32 PM   #3
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day fofa

Also - before you go too far ... do some searching in the Pentax thread here
I seem to remember an 12-month old thread about the lens locking pin causing some 3rd-party film-camera K-mount lenses to not remove from the camera body as expected

Regards, Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Jan 14, 2013, 4:50 PM   #4
Senior Member
 
fofa's Avatar
 
Join Date: Oct 2005
Posts: 547
Default

yea it has the P pin, but it is very, very shallow, I just can't see it causing an issue. I think the ones that get "stuck" are longer.

Thanks for the info, I'll check it out.
fofa is offline   Reply With Quote
Old Jan 15, 2013, 4:34 AM   #5
Senior Member
 
jachol's Avatar
 
Join Date: Aug 2006
Location: NW. England
Posts: 1,201
Default

fofa,

In case you can't access the original mod info, here's a pic of the lens I modded
I cutaway in the section indicated, the present length is approx 10mm as shown.
I removed the part from the lens, made the cut carefully with a junior hacksaw, smoothed the cut area with fine wet and dry paper, and finally applied matt black paint with a camel hair artists brush to finish off.

My lens mounts OK and works fine with these dimensions. ... Jack
Attached Images
 

Last edited by jachol; Jan 15, 2013 at 4:37 AM.
jachol is offline   Reply With Quote
Old Mar 2, 2013, 8:09 AM   #6
Senior Member
 
fofa's Avatar
 
Join Date: Oct 2005
Posts: 547
Default

Turns out I just had to remove the P pin. Turned out it was not allowing the lens to go on. The hardest part was finding a screw driver to fit the screws.
fofa is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:25 AM.