Go Back   Steve's Digicams Forums >


Reply
 
LinkBack Thread Tools Search this Thread
Old Jul 22, 2008, 10:57 PM   #11
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,177
Default

LOL! The board does that every so often. Let me add my congrats to the bunch, all three pictures are wonderful. Looks like you aren't going to have any trouble adjusting to the new camera at all. And you'll notice how those top quality lenses really shine with it, too.
mtngal is offline   Reply With Quote
Old Jul 23, 2008, 11:29 AM   #12
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

Great shots! The detail in #1 is awesome...cheers...Don
thekman620 is offline   Reply With Quote
Old Jul 23, 2008, 12:00 PM   #13
Senior Member
 
Pastorbbc's Avatar
 
Join Date: Nov 2007
Location: Morganton, NC
Posts: 228
Default

Thanks everyone. It is a cloudy day today -- I hope to get try out my new stuff this weekend.
Pastorbbc is offline   Reply With Quote
Old Jul 23, 2008, 12:51 PM   #14
Senior Member
 
Dal1970's Avatar
 
Join Date: Aug 2006
Location: Essex, UK
Posts: 1,868
Default

Great shots - looks like there will be no learning curve....


Dal
Dal1970 is offline   Reply With Quote
Old Jul 23, 2008, 2:38 PM   #15
Senior Member
 
rhermans's Avatar
 
Join Date: Jun 2005
Location: Antwerp - Belgium
Posts: 3,454
Default

magnificent shots,
don't even dare to pick a favorite, they're to good for that
rhermans is offline   Reply With Quote
Old Jul 23, 2008, 3:32 PM   #16
Senior Member
 
Pastorbbc's Avatar
 
Join Date: Nov 2007
Location: Morganton, NC
Posts: 228
Default

Thanks Dal and Rhermans - you are very kind.
Pastorbbc is offline   Reply With Quote
Old Jul 23, 2008, 3:51 PM   #17
Senior Member
 
robar's Avatar
 
Join Date: Mar 2005
Location: D/FW area Texas
Posts: 7,590
Default

Pastorbbc wrote:
Quote:
Didn't really mean to stutter here -- don't really know what I did???? Sorry about that.
it's from punching the send button after you already have. if you think the forum is not posting then copy your reply and go back,reload and see if it has gone thru. be SURE you copy because there is no mercy at steve's. i don't know how many replies(big ones) have been lost due to this problem. even those of us that have been here forever get occasionally ..

http://picasaweb.google.com/roysphoto
roysphoto @ Gmail.com
robar is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:26 PM.