Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Sep 7, 2006, 8:20 PM   #1
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

My wife and I went for a drive over the weekend and got a few photos of some wild flowers.



Jim
Attached Images
 
JimInGA is offline   Reply With Quote
Sponsored Links
Old Sep 7, 2006, 8:20 PM   #2
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

Second one
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 8:21 PM   #3
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

and another
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 8:22 PM   #4
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

Also saw a few bugs.

Jim
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 8:22 PM   #5
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

And the dragonflies



Jim
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 8:23 PM   #6
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

They kept getting more colorful



Jim
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 8:24 PM   #7
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

The last one.



Jim
Attached Images
 
JimInGA is offline   Reply With Quote
Old Sep 7, 2006, 9:03 PM   #8
Senior Member
 
Rickst's Avatar
 
Join Date: Jun 2004
Posts: 1,599
Default

All of them are very good. I especially like the 3rd one--totally alien looking plant
Rickst is offline   Reply With Quote
Old Sep 7, 2006, 9:06 PM   #9
Senior Member
 
wadue's Avatar
 
Join Date: May 2006
Posts: 914
Default

NIce shots, Jim! What lens did you use?

Ron
wadue is offline   Reply With Quote
Old Sep 7, 2006, 9:35 PM   #10
Senior Member
 
JimInGA's Avatar
 
Join Date: Feb 2006
Location: Georgia
Posts: 307
Default

Wadue,

All were shot using a Quantaray 70-300mm 1:4-5.6 LD. It's a tele-macro, but I didn't use the macro setting for any of the photos. Kept that lens on the camera, cause I never knew when I was going to want to reach out for a photo. The lens I believe is made by Sigma for Wolf Camera. I got it as a set with the kit lens when I got my DL. It seems kind of soft on full zoom and I keep telling myself I'll upgrade, but until I do, it works.

Thanks for the comments on the photos.

Jim
JimInGA is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:09 AM.