Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Nov 5, 2006, 6:15 PM   #1
Junior Member
 
NatureAdmirer's Avatar
 
Join Date: Oct 2006
Posts: 12
Default

Newly get on board of this cool forum. I'm now playing with my Pentax-M 50mm f1.7 on a K110D. One problem I found is that no matter what aperture I set on the lens (Can't set it on the camera, right?), the camera always uses the same shutter speed on a give scene. I expected that when I use different apertures, the camera should use different shutter speed accordingly. It seems to me that it takes pictures with aperture wide open. This was done in Aperture Priority mode. The second problem I found is that if I set the camera to M mode, the metering does not work. Unlike using my kit lens, there is no indication if a given combination of aperture and shutter speed will give a "correct" exposure value. In addition, in M mode, when I turn the switch to DOF preview position, I see the aperture diaphram changes to the positions I set. But when swith to Av mode, it does not respond. Are these the "normal" behaviour or did I miss something in "correctly" using my M lens?

Jason
NatureAdmirer is offline   Reply With Quote
Sponsored Links
Old Nov 5, 2006, 6:21 PM   #2
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

Hi Jason,

Your camera is working correctly. This is something I only recently figured out myself. To use an M lens or an equivelant from another brand you must be in M mode, otherwise it will shoot at the widest aperture. In M mode, you can set the metering by using the AE-L button. You will hear the camera stop the lens down and see the viewfinder get darker momentarily. You only need to reuse the AE-L button when lighting conditions change. It takes a little bit to learn, but after you have done it a few times it becomes much easier to remember.

Tim
NonEntity1 is offline   Reply With Quote
Old Nov 5, 2006, 6:30 PM   #3
TDN
Senior Member
 
TDN's Avatar
 
Join Date: Jun 2006
Posts: 1,288
Default

Did you go to "custom settings" and set the "allow aperture ring" option to "on" ?
TDN is offline   Reply With Quote
Old Nov 5, 2006, 9:12 PM   #4
Junior Member
 
Join Date: Oct 2006
Posts: 28
Default

one gripe i have found with this method with my M lens as well is that whilst the AE-L button works great for metering natural light, i cannot get the camera to factor in the flash as well. most of the time, if i am using flash with my M lens I have to set the shutter to 180th of a sec and then experiemnt with the aperture ring to get the right expo. if anyone knows how to get flash accounted for in the metering it'll be great

sho33y is offline   Reply With Quote
Old Nov 5, 2006, 9:18 PM   #5
Senior Member
 
nadnerb's Avatar
 
Join Date: Aug 2005
Location: Bath, UK
Posts: 319
Default

I have the same problem using the flash.
My solution funnily enough is exactly the same as yours!

nadnerb is offline   Reply With Quote
Old Nov 5, 2006, 9:46 PM   #6
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

Make me three. I just figured there was something I was doing wrong and still needed to figure out (there are a lot of those). Luckily, I only tend to use my fully manual lenses in good light so it has not been too much of an issue but I have lost some shots because of this issue.

Tim
NonEntity1 is offline   Reply With Quote
Old Nov 6, 2006, 11:02 AM   #7
Senior Member
 
Join Date: Sep 2004
Location: Wigan, UK
Posts: 568
Default

I use manual external flash, so I just set the aperture on the lens, shutter at 1/180s and adjust flash output. I think build in flash always discharges at full strenght in this case. (maybe try reading manual?)

greg
gfurm is offline   Reply With Quote
Old Nov 6, 2006, 1:09 PM   #8
Senior Member
 
Join Date: Aug 2006
Location: Essex, UK
Posts: 1,868
Default

Through trial and error (and reading the manual) I found that the built-in flash always gives full flash unless you use the PIC modes. I tried setting the aperature to f16 for a macro, and blew the pic completely. Set the cam to macro and tried again with perfect results.

Got a Sigma flash now - much better.



Darren
Dal1970 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:07 AM.