Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Mar 8, 2007, 2:54 AM   #1
Senior Member
 
Join Date: Jan 2005
Posts: 692
Default

I don't know if it is my imagination, but since Pentax returned my camera's K10D's and since my firmware update, it seems that my exposures are better. They don't seem as underexposed...

However...I have a feeling, that rather than expressing certain defaults in a system and stating that they will be solving them as a firmware update, companies address these problems without any form of communication to the public and they disappear as if they never happened in the first place, so new users never even knew they existed as an issue.

http://www.pressbook.com/homebook.as...44&langue_id=2
http://anashcreation.com/thenashgallery/BenjaminKanarek
benjikan is offline   Reply With Quote
Sponsored Links
Old Mar 8, 2007, 3:23 AM   #2
Senior Member
 
Hayward's Avatar
 
Join Date: Jan 2007
Posts: 1,318
Default

I hope they keep this ACTIVE updating up..... 10D barely out 4 months and already SECOND firmeare update.... and not for CHRONIC problem reasons.

Hope they keep this up.

And first 1.10 update came very soon after production release likely from BETA testing.
Hayward is offline   Reply With Quote
Old Mar 8, 2007, 3:29 AM   #3
Senior Member
 
Join Date: Jan 2005
Posts: 692
Default

Hayward wrote:
Quote:
I hope they keep this ACTIVE updating up..... 10D barely out 4 months and already SECOND firmeare update.... and not for CHRONIC problem reasons.

** Hope they keep this up.
I am quite sure that they will. I have a feeling that they are also addressing the possibility of including a 3200 iso provision amongst other useful features...
benjikan is offline   Reply With Quote
Old Mar 8, 2007, 7:35 AM   #4
Guest
 
Posts: n/a
Default

hey ben,
guess we've been invaded.. welcome to the board!! even if someone else has already said it.. can't wait for the 16-50 examples.

roy
  Reply With Quote
Old Mar 8, 2007, 8:53 AM   #5
Senior Member
 
Join Date: Jan 2005
Posts: 692
Default

Hope to have it by the end of next week with the 50-135 & 31 Limited as well...
Attached Images
 
benjikan is offline   Reply With Quote
Old Mar 8, 2007, 1:26 PM   #6
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,052
Default

Welcome to our group over here - I LOVE your pictures.

Have you installed the new firmware? I downloaded it but haven't had a chance to actually install it. Was wondering what your thoughts were about it - what they published didn't make it sound like as big of an update as the first one.
mtngal is offline   Reply With Quote
Old Mar 8, 2007, 4:52 PM   #7
Senior Member
 
Join Date: Jan 2005
Posts: 692
Default

As I said in an earlier post...These are my impressions.
I don't know if it is my imagination, but since Pentax returned my camera's K10D's and since my firmware update, it seems that my exposures are better. They don't seem as underexposed..
I have a feeling, that rather than expressing certain defaults in a system and stating that they will be solving them as a firmware update, companies address these problems without any form of communication to the public and they disappear as if they never happened in the first place, so new users never even knew they existed as an issue.
When my update was done, all my "tweaks" were preserved.

As to the ergonomics of the K10D. Absolutely astounding. My major critique to Pentax was the absence of a dedicated Synchro X Cable Input. That was a major omission. Yes I use a Radio slave, but what if it fails me? I do have the Hot shoe synchro adapter by Hama, but it is not well placed for a synchro. The cable hangs over the view finder..
__________________
Attached Images
 
benjikan is offline   Reply With Quote
Old Mar 8, 2007, 7:45 PM   #8
Senior Member
 
Robert Barnett's Avatar
 
Join Date: Mar 2007
Posts: 323
Default

How do you decide if your K10D needs to be sent in? I mean how do you know that something you don't like about the final image quality is the camera and not the nut pressing the shutter button or something else like a badly aligned lens?

Sometimes I wonder if the softness I am seeing in images is how it is supposed to be or if there is something out of wack with the camera or if I have a monkeyed up lens.

Robert
Robert Barnett is offline   Reply With Quote
Old Mar 9, 2007, 3:33 AM   #9
Senior Member
 
Join Date: Jan 2005
Posts: 692
Default

When you check, double check triple check and quadruple check your focus and shoot under less adverse lighting conditions than what caused you the problem in the first place..If it isn't in focus..In it goes.

Ben
benjikan is offline   Reply With Quote
Old Mar 11, 2007, 6:30 PM   #10
Senior Member
 
ennacac's Avatar
 
Join Date: Mar 2005
Posts: 4,198
Default

I just installed the new firmware and my K10D now exposes much better than it did before the instillation.

Tom
ennacac is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:05 PM.