Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Jun 23, 2007, 5:30 AM   #1
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Hello my dear Pentax owners/fans!

Yesterday I'm proud & happy to own for the first time in my live a Pentax brand camera, this time a K10D Kit one.

Below you will see my attached photo of what I acquired!

During meantime, I found (For my erudition's...of course!), a defect as my others P&S ones which use the same SF type memory cards...don't had this particular syndrome!?, for this sole reason I'm asking to all of you your erudite & most accurate input...of what really happen, as from the owners Instruction Manual..seriously I can't understand that MUST be as I will try very hard for me in English such defect/syndrome!.

I load the SD card chamber as instructed...after that I opened the card door with the back key..format the card show me at better 10Mb size near 1,124 photos...make 44 test photos...& when i tried to "Draw back"...the card from the slot...pushing so will move a few "Centimeters"...so will be easier for my finger to grasp the back of the card...what really happen is that such "Springy" movement back for easy to be draw back...'DON'T EXIST"...? The card REFUSES to move back...I press again in...more firmly...same results??? BTW...that camera came factory sealed from US. with Instructions in English from Denver, address...so it's an a officially imported "Complete Kit" to US...NOT a "Gray" one!. BTW...I get the firmware 1.00!:?

Or...maybe my received Transcend card came a "Little bit" more bigger/thicker...who knows...I leave it inside...& download my photos with the cord provide among body & USB front socket on my computer! As the battery (Made in Japan), was fully charged...don't upset me!

Thanks in advance for your good will with me & my problem!

Peace,

Alex 007:|
Attached Images
 
Alex 007 is offline   Reply With Quote
Sponsored Links
Old Jun 23, 2007, 7:42 AM   #2
Senior Member
 
Black Knight's Avatar
 
Join Date: Feb 2006
Location: Oxford, CT
Posts: 1,309
Default

Hi Alex 007

First let me say welcome To the forum. I have a K100D and a DS, not the K10.

If it were me, I Would get hold of a different SD card and try that.

We have several Members Here with K10Ds, hopefully they Will be able To help

Phil
Black Knight is offline   Reply With Quote
Old Jun 23, 2007, 8:09 AM   #3
Senior Member
 
ennacac's Avatar
 
Join Date: Mar 2005
Posts: 4,198
Default

I have a Transcend. 150x, 2GB SD card and have had no problems with it at all. If I understand your post, you can no longer remove the card from your K10D and it is stuck in the slot, is that correct?

I have never heard of that problem at all. Is it a normal SD card, or is it one that converts to a USB port if you fold it in half?

Tom
ennacac is offline   Reply With Quote
Old Jun 23, 2007, 8:48 AM   #4
Senior Member
 
Join Date: Jun 2006
Posts: 179
Default

I wonder if this means anything --

The box as shown says "SD COmpatible" and not SD...to me there is a difference in "SD" and "SD Compatible".

FWIW

Feroz
fghouse2000 is offline   Reply With Quote
Old Jun 23, 2007, 8:49 AM   #5
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

ennacac wrote:
Quote:
I have a Transcend. 150x, 2GB SD card and have had no problems with it at all. If I understand your post, you can no longer remove the card from your K10D and it is stuck in the slot, is that correct?

I have never heard of that problem at all. Is it a normal SD card, or is it one that converts to a USB port if you fold it in half?

Tom
My dear Tom,

YES...you comprehended correctly...just now I was able with very difficulty to remove this particularly get in card & instead I load a "Blue Kingston" one of 1GB made in Japan....slip in the slot easily & can be removed pushing again the card "Jump" outside easily...so it's a defect on my "Transcend 4GB 150x" card...which after looking extremely well I CAN'T find any engraved sentence of where was made/serial number...etc... which the Blue Kingston has...really I'm thinking that MAYBE...is some kind of "FAKE" card...whatever was received sealed on an a small hard plastic blister!!??:?

Among us...is true...IF...only IF...I load this specific 150x card & LEAVE it inside the Pentax received body for EVER!!!...& download my photos with the get in cord...it's O.K...but rethinking again...NO...NO...the card MUST "ENTER & or EXIT"...easily...I'm correct?:P

Thanks so much for your heart fully help!

Peace,

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Jun 23, 2007, 8:55 AM   #6
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

I have a Transcend 4gig card that is ever so slightly thicker or wider than my other cards, including other transcend cards. In my k100d it "sticks" for a fraction of a second whenever I insert it or remove it. It has never gotten all the way stuck, though. When I insert it, it sticks for a moment all the way in before it pops back out slightly to where it should be. When I remove it, it sticks pushed all the way in for a moment before it pops out to where I can grab it.

So I suspect the issue is your card and perhaps yours is slightly thicker or wider even than mine is. If you can get it to pop out try another card (I have Kingston and Transcend 1 and 2 gig cards that do not do this).

Good luck!

Tim
Edit: I just noticed that your Transcend card is the 150x 4 gig. This is the exact same card that I have the issue with.
NonEntity1 is offline   Reply With Quote
Old Jun 23, 2007, 8:55 AM   #7
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

fghouse2000 wrote:
Quote:
I wonder if this means anything --

The box as shown says "SD COmpatible" and not SD...to me there is a difference in "SD" and "SD Compatible".

FWIW

Feroz
UPS!!!!!

Thanks so much my dear Feroz...really I don't look well yes you are 500% correctly...it's NOT SD as the Blue Kingston that I load it now...which enter & exit from the slot very easy & faster...with NO problem at all...Thanks again for your cute eyes!

Surely I will return back to the seller... tomorrow Sunday here in israel is an anormal working day...so I will phobe him...asking for exchanged with another one "SD" only...Compatible...OUT!!!:shock:

NOW...I will write to Transcend in US asking the differences!:?

Peace,

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Jun 23, 2007, 9:05 AM   #8
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear Tim,

Take not at my attached photo that Feroz noticed that on the card packaged is write "SD COMPATIBLE"...which say to me & maybe same with your same capacity Transcend brand card...look at your booklet that was inside the Blister (Look at my photo...for better comprehending!), if it's write like mine "SD COMPATIBLE":?

If it's the same...so...it's NOT good...as I already wrote to Feroz...if you or I don't withdraw the card & load once...no touching anymore it's O.K.:yawn:

But...if you like to change among all your cards collection...it's NOT good...forcing it each time that you want to exit it :angry:

Tim...yours also say "SD COMPATIBLE":?

Peace,

Alex 007:|
Alex 007 is offline   Reply With Quote
Old Jun 23, 2007, 1:20 PM   #9
Senior Member
 
ishino's Avatar
 
Join Date: Oct 2006
Posts: 661
Default

I have a K10D and a Transcend 150x 4GB SD card. It is a snug fit, but mine does load and eject without problems. However my blister pack looked differently, but that might be because I bought mine in the USA. More importantly my card also has a serial number printed on the back of the card along the side of the lock slider. There also looks to be something imprinted on the label on the front of the SD card, but I can't read it. If the front label is not super thin, I suspect that the thickness of the label might be enough for your card to get stuck in the K10D, which might also mean it is an altered card. Compare the lables with your Kingston card for comparison.
ishino is offline   Reply With Quote
Old Jun 24, 2007, 12:36 AM   #10
Senior Member
 
Alex 007's Avatar
 
Join Date: Sep 2005
Location: Ariel/Israel
Posts: 1,177
Default

Dear Ishino,

I check now the back of the blister & I saw that the address is www.Transcendusa.com...so I think that is also imported from US, I take a photo which will show you what is the model & serial number of my specific received card.

Also now I load a Kingston blue "Normal" speed which fits easily & can be withdraw from the slot exactly the same very easily, pressing once the back of the card & the card "Jump' slight out...making for my finger much easier to exit it.

BTW...already wrote to the "Customer' services at Transcend US...yesterday so today is Sunday..don't work I will wait few day with a heart fully hope that will receive any response from them!:?

Peace,

Alex 007:|
Attached Images
 
Alex 007 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:20 AM.