Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Jul 1, 2007, 4:47 PM   #1
Senior Member
 
penolta's Avatar
 
Join Date: Apr 2007
Location: California USA
Posts: 5,206
Default

Yesterday an odd thing happened with the DG Super on the K10 - after several succesful exposures the flash froze up - the display remained lit, but it wouldn'tfire or test. Turning it off and on again had no effect, and the display remained on, even after removal from the camera. I decided to inturrupt the current by onening and closing the battery compartment door, and the flash returned to normal operation. The flash has operated normally on the K100 all along; ithas not been used much on the K10 before, but when it was used, it was without problens. Any elsehave this happen? Was it just a "computer crash/cold reboot" quirk or does it indicate a problem?

There wereone or twothreads not long ago about compatibility problems with these flashes if made before the end of last year (about when I bought this one), requiring rechipping for use with the newer Pentax DSLRs (I think one mentioned "rebooting" but I couldn't find it), and I had sent Sigma customer service an inquiry with the serial number of my flash, but they never responded. Has any one with a serial number higher than 8054069 had to send it in for rechipping?
penolta is offline   Reply With Quote
Sponsored Links
Old Jul 24, 2007, 10:08 PM   #2
Senior Member
 
penolta's Avatar
 
Join Date: Apr 2007
Location: California USA
Posts: 5,206
Default

I found out on another forum that according to a notice from Sigma technical service in response to a question of K10D compatibility that any of these these flashes with serial numbers below 8063038 "will need to be upgraded . . . to work [properly] with these cameras." I finally called Sigme and described the problem, which they said was defina\itely abnormal, and to send it in. The technician was noncommital about the upgrade. I sent it off with a description of the problem and a request for an upgrade. I heard nothing from them, but 10 days later it was on my doorstep! The service work order was marked "REPAIRED" with the notation "Firmware update zoom unit adjusted checked all good working order" No explanation, and no charge. But it was fast. Now let's see if the problem reoccurs.
















penolta is offline   Reply With Quote
Old Jul 24, 2007, 10:41 PM   #3
Senior Member
 
robar's Avatar
 
Join Date: Mar 2005
Location: D/FW area Texas
Posts: 7,590
Default

penolta wrote:
Quote:
I found out on another forum that according to a notice from Sigma technical service in response to a question of K10D compatibility that any of these these flashes with serial numbers below 8063038 "will need to be upgraded . . . to work [properly] with these cameras." I finally called Sigme and described the problem, which they said was definaitely abnormal, and to send it in. The technician was noncommital about the upgrade. I sent it off with a description of the problem and a request for an upgrade. I heard nothing from them, but 10 days later it was on my doorstep! The service work order was marked "REPAIRED" with the notation "Firmware update zoom unit adjusted checked all good working order" No explanation, and no charge. But it was fast. Now let's see if the problem reoccurs.

Quote:
i've the DS and the 500super. from other users i've found out that my sigma will need to be rechipped for the k10 when/if ever i get it.SR #8054025
Quote:
Quote:
i assume penolta is because you shoot with both.
do you have a name ???
Quote:
roy










robar is offline   Reply With Quote
Old Jul 24, 2007, 11:07 PM   #4
Senior Member
 
penolta's Avatar
 
Join Date: Apr 2007
Location: California USA
Posts: 5,206
Default

Quote:
i've the DS and the 500super. from other users i've found out that my sigma will need to be rechipped for the k10 when/if ever i get it.SR #8054025
I was told to send in my warranty card with the flash, so if you think you will ever get a K series body, get it rechipped for free now,before your warranty runs out.

And yes, I shoot with both, since I had lenses for both systems having changed film cameras from Pentax to Minolta when autofocus came out.
penolta is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:39 PM.