Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Jul 31, 2008, 5:49 PM   #1
Senior Member
 
Goldwinger's Avatar
 
Join Date: May 2008
Location: Winter Haven, Florida
Posts: 6,515
Default

Well Gang,
Looks like I get to send my camera back again!:?
When I first got it back (they sent a new one) it worked fine. Then it started doing strange things, like not changing exposure settings properly, seemingly staying in one mode when I switched to another and things like that. Then it starts working fine.:-? A couple weeks ago, when I got the good pics of the tri color heron and the great blue I was using my 28-200mm lens and got some nice clear shots at 200mm hand held. Last Friday I was using the same gear and couldn't get a sharp image for the life of me, even at 70mm and 1/1000 shutter. Not only that but I put it continuous shooting mode to take a series of shots and it suddenly locked up on me with the shutter open. I tried everything to get it back to normal with no luck until I finally had to remove the battery. Then it seemed to work ok. Well today I was taking some test shots a manual lens, then when I switch back to my "A" lens it wouldn't recognize it.(asked for the focal length at start up and wouldn't register an F: stop in the display.) I switched to the kit lens and it seemed to recognize it but, when I pressed the shutter half way to focus, the aperture stopped way down and I could barely see through the view finder. Nothing I tried made any difference. So… back to square one, now I'll be without a camera for another month! Somebody please tell me it gonna be alright…
:angry:

GW
Goldwinger is offline   Reply With Quote
Sponsored Links
Old Jul 31, 2008, 6:12 PM   #2
Senior Member
 
Wingman's Avatar
 
Join Date: Dec 2003
Location: Hebron, Kentucky (northern Kentucky/Greater Cincinnati):KCVG
Posts: 4,327
Default

Sorry to hear about your bad karma GW.I trust that it is under warranty. Hope you get it back soon and can serve us with more pics!

Jay
Wingman is offline   Reply With Quote
Old Jul 31, 2008, 9:11 PM   #3
Senior Member
 
Goldwinger's Avatar
 
Join Date: May 2008
Location: Winter Haven, Florida
Posts: 6,515
Default

Thanks Jay,
what can I say? the gods are against me! :lol:
Goldwinger is offline   Reply With Quote
Old Jul 31, 2008, 10:19 PM   #4
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

Goldwinger wrote:
Quote:
Thanks Jay,
what can I say? the gods are against me! :lol:
AAH. But your friends are with you.....well I haven't asked any of them lately.....but I'msure they must be!!! :evil::G

Dawg

bigdawg is offline   Reply With Quote
Old Jul 31, 2008, 10:23 PM   #5
Senior Member
 
bigdawg's Avatar
 
Join Date: Feb 2005
Location: Thach Alabama
Posts: 14,981
Default

NAAAH! I can't let that be the only answer. I truly do hope this one works out for you....UHH! You haven't been tying the camera to a stick and fending off gators with it have you?

Dawg
bigdawg is offline   Reply With Quote
Old Jul 31, 2008, 10:32 PM   #6
Senior Member
 
Rodney9's Avatar
 
Join Date: Nov 2006
Location: Yeronga, Brisbane, Queensland, Australia
Posts: 3,518
Default

What can I say ? not fair. Maybe a bad batch ? I hope you get one back fully ok and fast.

Rodney.
Rodney9 is offline   Reply With Quote
Old Jul 31, 2008, 11:17 PM   #7
Senior Member
 
nhmom's Avatar
 
Join Date: Jun 2006
Location: Southern New Hampshire
Posts: 5,202
Default

Sorry to hear of your bad news, John. I really am! But, I'm going to have to start calling you "Alex".

We have a temp at work this summer who has managed to have everything he touches stop working. He reads water meters and the roadrunner he's been using I just sent back to be repaired today for the third time in two months. A second one he's used, the screen keeps going out on him. And, on top of that, the car he was driving today blew up on him. The catalytic converter got a hole in it and caught the car on fire.

Only kidding. I'll still call you John. (But, I'll be thinking Alex the whole time.:-))

I do hope you get either this one back working great or another new one that is in tip top shape.

Looking forward to seeing more of your photos.

Patty


nhmom is offline   Reply With Quote
Old Jul 31, 2008, 11:23 PM   #8
Senior Member
 
snostorm's Avatar
 
Join Date: Jan 2004
Location: Chicago Suburb, IL, USA
Posts: 2,770
Default

Hi GW,

It probably was a karma thing. . . IIRC, you got that extra lens, battery, and all the rest of the accessories with the replacement body. . .for the one that you broke. . . and the camera body was probably upset with your consideration of covering it up with a rubber suit. . .:-) (just kidding. . .)

If you tell the whole tale of woe, and this being so soon after getting the replacement. . . maybe they'll put a rush on it -- I'd say it's worth a phone call playing up how disappointed you are. . .:sad:

Here's hoping for a speedy fix to your problem.

Scott
snostorm is offline   Reply With Quote
Old Aug 1, 2008, 2:31 AM   #9
Senior Member
 
Lyrics51's Avatar
 
Join Date: Jan 2007
Location: Northwest Ohio
Posts: 1,954
Default

GW, Sounds like you are a "Man of Constant Sorrows." I hope they give you a new camera this time. Probably won't happen, but I would at least ask.

Glenn
Lyrics51 is offline   Reply With Quote
Old Aug 1, 2008, 11:06 AM   #10
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

Man that stinks! Here is hoping they get you taken care of quickly!

Tim
NonEntity1 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:40 AM.