Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Sep 30, 2008, 6:12 PM   #1
Junior Member
 
Join Date: Sep 2008
Posts: 2
Default

Am I the only one with a Pentax that is apparently a piece of junk. This camera has been used very little.

After I had had it for few months the LCD begin to intermittently fail to show any information. No review, no menus no nothing, just a bright white screen. I sent it back to Pentax and when I got it back and it worked for a while.

A year or two later, the same thing happened. I took it to a local reputable repair facility and for $250 I was told it had had a loose connection and was now fixed.

Again it worked for while and then the SAME THING AGIN. It is now back in the shop.

I am sick of it.

Koochiching is offline   Reply With Quote
Sponsored Links
Old Sep 30, 2008, 7:46 PM   #2
Senior Member
 
Goldwinger's Avatar
 
Join Date: May 2008
Location: Winter Haven, Florida
Posts: 6,515
Default

well...
First let me say welcome to the forum.
I think most of the folks here have been happy with there cameras but, like you there are a few of us that have had problems. I've been having problems with my Samsung ever since I bought it. it's been back for repair 3 times now and it's acting up again. yes I'm sick of it too. all that being said, I still think they have a pretty good product overall. if you check out other forums, you'll pretty much find the same rate of happy - unhappy customers for Canon, Nikon, whatever. I'm really sorry you're having such a time with yours, believe me I know just how it feels.

GW:bye:
Goldwinger is offline   Reply With Quote
Old Sep 30, 2008, 8:54 PM   #3
Senior Member
 
snostorm's Avatar
 
Join Date: Jan 2004
Location: Chicago Suburb, IL, USA
Posts: 2,770
Default

Koochiching wrote:
Quote:
Am I the only one with a Pentax that is apparently a piece of junk. This camera has been used very little.

After I had had it for few months the LCD begin to intermittently fail to show any information. No review, no menus no nothing, just a bright white screen. I sent it back to Pentax and when I got it back and it worked for a while.

A year or two later, the same thing happened. I took it to a local reputable repair facility and for $250 I was told it had had a loose connection and was now fixed.

Again it worked for while and then the SAME THING AGIN. It is now back in the shop.

I am sick of it.
Hi KCC,

You haven't been dealt the best cards, but I really don't think that you're justified in calling the DS "junk" because of your experience. The DS, as far as I know, has been an extremely reliable body in the great great majority of cases. My experience in over two years of carrying my DS virtually everywhere, usually with 2-5 lbs of glass hanging off the mount, and the over 40,000 shots it's taken, is that the DS is more than just durable, especially in its price class. I still have and use it, and will keep it until it falls apart or dies completely. . .

You might have a legit gripe against Pentax Service, but it's a bit thin, IMO. Their repair could conceivably be criticized for not being optimal (there shouldn't have been a recurrance of the same problem), but it did, according to your post, last either a year or two. The same cannot be said of your local camera repair shop. They charged you a pretty steep fee considering the relatively easy isolation of the problem, and they didn't do the repair even as well as Pentax originally did. I'd say that your main gripe at this time, is with the local shop. I'd have them specify the exact repair that they did (ie resolder the connection, replace the connector, or whatever) and maybe throw in an extended repair warranty in writing for your trouble.

There should be no recharge for the re-repair, regardless of what the current problem is because there is no way to tell if their faulty repair might have caused the present problem. (In other words, I'd not accept being charged for a burnt out circuit board or LCD screen since their repair could have caused the present problem)

I hope that your situation is taken care of this time around, but I doubt that posting your problem here on a Pentax forum, putting the blame on the camera, was a very reasonable way to vent your frustration.

Scott
snostorm is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:37 AM.