Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Sep 8, 2009, 9:38 PM   #11
Senior Member
 
robar's Avatar
 
Join Date: Mar 2005
Location: D/FW area Texas
Posts: 7,590
Default

tim,
this could be the sensor but it could also be a memory prob. not the card but the internal memory
__________________
Roy
Passion is in all great searches and is necessary to all creative endeavors. - W. Eugene Smith
http://picasaweb.google.com/roysphoto/?pli=1
robar is offline   Reply With Quote
Old Sep 8, 2009, 9:40 PM   #12
Senior Member
 
nhmom's Avatar
 
Join Date: Jun 2006
Location: Southern New Hampshire
Posts: 5,202
Default

Tim,

Sorry to hear of your plight. I've often wondered why there weren't more problems like these with all the electronics in them. Good luck with your new one.

Patty

p.s. How long have you had your K20? How many images taken? Just curious.
nhmom is offline   Reply With Quote
Old Sep 9, 2009, 12:28 PM   #13
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

Patty, I just downloaded PhotoME and it says I have 22,800 shots taken. I would have guessed higher. I appreciate all the advice and well wishes everyone, I should not be Pentax-less for long. I did spring for a the two year extended Pentax warranty, which Adorama is offering as an add-on for $10. It says not valid in Florida, but hopefully that is a restriction on selling it and does not mean they won't honor it here. Regardless, it was worth $10 to gamble.

Tim
NonEntity1 is offline   Reply With Quote
Old Sep 10, 2009, 2:47 AM   #14
Senior Member
 
rhermans's Avatar
 
Join Date: Jun 2005
Location: Antwerp - Belgium
Posts: 3,454
Default

Hope everything works out great and you get a new one (pentax paying off course)

Ronny
__________________
rhermans is offline   Reply With Quote
Old Sep 30, 2009, 7:20 PM   #15
Senior Member
 
NonEntity1's Avatar
 
Join Date: Jul 2006
Location: Lake Placid Florida USA
Posts: 2,689
Default

I received word from Pentax, it was the sensor that failed. The cost of the repair would have been within $150 of what I had just paid for a new K20d with a three year warranty. I debated but decided I would rather save the money towards a K7 later on. It was disappointing news but I am happy the prices on my replacement had gotten so low.

Tim
NonEntity1 is offline   Reply With Quote
Old Oct 2, 2009, 1:16 AM   #16
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,056
Default

Sorry to hear that it was the sensor - definitely a premature failure. It's also not surprising that it was an expensive fix and I think you made the right choice to save for the K7. The more I use the camera, the more I see how much better it suits me.
mtngal is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:06 PM.