Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Dec 9, 2009, 12:15 AM   #1
Senior Member
 
The_Other_One's Avatar
 
Join Date: Jan 2004
Posts: 112
Default Still learning the K-x

Got my K-x about a week ago, received my AF-360FGZ yesterday. Still getting used to everything and tweaking all the settings... For those curious, my only real problems with the camera is the fact it uses AA batteries (which might also account for the quirky battery levels). It also doesn't feel as solid as my Nikon D40, but still a very sturdy camera...
__________________
Darren
~Minolta Dimage Xt
The_Other_One is offline   Reply With Quote
Sponsored Links
Old Dec 9, 2009, 7:29 AM   #2
Senior Member
 
Join Date: Nov 2004
Location: Mount Shasta, California
Posts: 1,525
Default

There is a firmware fix for the battery read problem. Check Pentax website.
pboerger is offline   Reply With Quote
Old Dec 9, 2009, 12:42 PM   #3
Senior Member
 
The_Other_One's Avatar
 
Join Date: Jan 2004
Posts: 112
Default

I've upgraded to 1.01 already. While it might help some, the battery level is still quirky. For example, I'll use liveview for a bit and the battery will show empty/red, but once I go back to regular mode, it'll jump back to half-charge. But at least it's not done like before and said "batteries depleted" and shut off, only to turn back on and continue working for days on the same batteries :P
__________________
Darren
~Minolta Dimage Xt
The_Other_One is offline   Reply With Quote
Old Dec 9, 2009, 2:10 PM   #4
Junior Member
 
queyan's Avatar
 
Join Date: Dec 2009
Posts: 22
Default

Very nice picture of your cat.

I, too, had the issue with the batteries that came with the camera. I put them in, got the battery depleted message, and then the camera powered off. I promptly powered it on and, to this day, I'm still using the original batteries from three weeks ago. I've probably taken about 300 shots and the battery indicator still shows all green.
queyan is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:59 AM.