Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Aug 3, 2010, 2:35 PM   #11
Senior Member
 
Join Date: Mar 2007
Posts: 515
Default

Quote:
Originally Posted by Frogfish View Post
I had a very close shave today - tried to update the Firmware (following the Pentax instructions and those of the previous thread on this forum) and the camera said the Firmware was corrupted. Tried again - same thing. Then the camera refused to recognise the SD card and I feared the worst.

The camera refused to reformat the card so I took it to the Mac reformatted it there and then back to the camera - second time around it reformatted it OK. However now and again when switching on it still says the SD card is damaged and I have to reformat it again (in camera). This has really put me off upgrading my firmware.
SD cards are relatively cheap. A lot cheaper than having to have your camera repaired.

I think you should get a new/different card to use for your update.

Ed
__________________
Canon 60D, EF 50 f/1.8 II, EF 85 f/1.8 EF-S 10-18 f/4.5 - 5.6, EF-S 18-135 f/3.5 - 5.6, EF 24-105 f/4L, 430 EX II


Pentax K1000, A50 f/1.7, M135 f/3.5, A70-210 F/4

www.EdWoodsonPhotography.com
EddyinGA is offline   Reply With Quote
Old Aug 3, 2010, 2:36 PM   #12
Senior Member
 
Frogfish's Avatar
 
Join Date: Feb 2006
Location: Shanghai, China
Posts: 2,774
Default

Quote:
Originally Posted by mtngal View Post
It might also be that the card has a problem, not the firmware. Have you tried a different card? They don't last forever, and can become damaged (though the Sandisks I've been using seem to hold up quite well).
I've never had any problem with the card and it's only a few months old (Sandisk 3 Extreme). I doubt it's the card but I'm very suspicious of the firmware having being corrupted during the download somehow (twice) !
Frogfish is offline   Reply With Quote
Old Aug 4, 2010, 1:10 AM   #13
Senior Member
 
Tachikoma's Avatar
 
Join Date: Jul 2007
Location: Wales
Posts: 1,086
Default

I had this problem with XD cards, they would just randomly corrupt for no reason, after a format they would be fine for another 6-odd months.
Tachikoma is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:58 AM.