Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Aug 10, 2010, 4:00 PM   #1
Senior Member
 
Eetu's Avatar
 
Join Date: Jan 2010
Location: Jyväskylä, Finland
Posts: 2,212
Default Shooting video with the K-7

Hiya! I have one question. I recently update my K-7 with latest firmware. And, for the first time, I thought I would test out the video mode. I have a question: Why is that on the two highest quality levels, when I start to record... it only last about 30 seconds and then I get this hour glass... and that's it. When I got the camera, I bought a high speed, top of the line 8 GB memory card.

Any ideas?

Ned
Eetu is offline   Reply With Quote
Sponsored Links
Old Aug 10, 2010, 8:40 PM   #2
Senior Member
 
Goldwinger's Avatar
 
Join Date: May 2008
Location: Winter Haven, Florida
Posts: 6,515
Default

Hey Ned,
I don't know, because I don't have the K-7 but, I'm under the impression you must have a card that is rated for HD video in order to capture constant video. Could that be it?
__________________
GW

Life's a breeze on a Goldwing...
Goldwinger is offline   Reply With Quote
Old Aug 11, 2010, 2:25 AM   #3
Senior Member
 
Eetu's Avatar
 
Join Date: Jan 2010
Location: Jyväskylä, Finland
Posts: 2,212
Default

Hi John, and thanks for your reply. I thought it might have to do with the card, but the card which I bought is the highest rated (6) and I special ordered it, paying around 50 euros... mind you it is 8 GB.

I tried it again, and sure enough 28 seconds... then comes the hour glass. My goal is take the longest clips available of in-laws, at the hghest quality, even if the clips don't last all that long in minutes... but 28 seconds. Holy cats!
Eetu is offline   Reply With Quote
Old Aug 11, 2010, 2:29 AM   #4
Junior Member
 
Join Date: Aug 2010
Posts: 4
Default

Check the video info and test the transfer speed of your SD card.
FCOI is offline   Reply With Quote
Old Aug 11, 2010, 3:56 AM   #5
Senior Member
 
Eetu's Avatar
 
Join Date: Jan 2010
Location: Jyväskylä, Finland
Posts: 2,212
Default

Hiya! I did check the video info as best as I can ascertain what the settings should be.... have no idea about testing the transfer speed of the SD card. Sorry
Eetu is offline   Reply With Quote
Old Aug 11, 2010, 8:36 AM   #6
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,452
Default

I had a similar problem with a particular class 6 card, just wouldn't do the HD video. A friend had the same card and worked fine, turned out to be a bad card.
__________________
[SIZE=1][SIZE=2]Any problems with a post or thread please use the report button at the bottom left of the post and the team will help sort it out.
Mark1616 is offline   Reply With Quote
Old Aug 11, 2010, 8:58 AM   #7
Senior Member
 
Eetu's Avatar
 
Join Date: Jan 2010
Location: Jyväskylä, Finland
Posts: 2,212
Default

Mark, I am beginning to think the same... last night was the first time I saw "memory card failure"... Hmmm... Sounds like I should get another card and use this one as a "backup". Nice hearing from ya. Thanks.
Eetu is offline   Reply With Quote
Old Aug 11, 2010, 9:00 AM   #8
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,452
Default

You're welcome. It's a pain when there is a card problem. All bar one of my cards now is Sandisk and the minimum is Extreme III, they work great, had no issues so I don't mind paying the extra for safety.
__________________
[SIZE=1][SIZE=2]Any problems with a post or thread please use the report button at the bottom left of the post and the team will help sort it out.
Mark1616 is offline   Reply With Quote
Old Aug 11, 2010, 9:37 AM   #9
Senior Member
 
Frogfish's Avatar
 
Join Date: Feb 2006
Location: Shanghai, China
Posts: 2,774
Default

I have a SanDisk Extreme III. Video stopped working after about a minute when videoing my wife's karaoke (and she's got a great voice so that was really a shame).
Frogfish is offline   Reply With Quote
Old Aug 11, 2010, 11:14 AM   #10
Senior Member
 
Eetu's Avatar
 
Join Date: Jan 2010
Location: Jyväskylä, Finland
Posts: 2,212
Default

Well is there a card that DOES work for using video on a Pentax K-7... Anyone want to chime in?
Eetu is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:05 AM.