Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Nov 6, 2010, 7:49 PM   #11
Junior Member
 
Join Date: Aug 2010
Location: NY
Posts: 9
Default

Quote:
Originally Posted by ctdkite View Post
I just got the Pentax K-x yesterday. All the pictures have the same two dots. I did the camera's dust removal system and changed lenses, but still have the problem.

You can see here: http://gallery.me.com/dodsonfam#100261

Did you get your problem fixed?
I purchased a "giottos" rocket air blower, it got most of the dust spots but I still have this one spot that does not go away.
nadz is offline   Reply With Quote
Old Nov 6, 2010, 10:33 PM   #12
Senior Member
 
Join Date: Jan 2010
Location: Western Ma. USA
Posts: 795
Default

i have the k-r, i have the camera set up to use the dust removal system every time the camera starts up. do you think this is actually worth while? (referring to rhermans comment)
__________________
ewheeler20 is offline   Reply With Quote
Old Nov 6, 2010, 11:10 PM   #13
Senior Member
 
Hawgwild's Avatar
 
Join Date: Mar 2006
Location: Pensacola, Florida
Posts: 3,547
Default

Eric, I have a Sony A300, which shakes the sensor at shutdown. I have owned the camera since Oct 2008, have shot nearly 5,000 pics, and used my rocket blower only once, about four months ago.

"do you think this is actually worth while? (referring to rhermans comment)"

Absolutely. Just consider it another helping hand in the fight against sensor dust.
__________________
Always use tasteful words - you may have to eat them.
You cannot find knowledge by rearranging your ignorance.

My Flickr
-Robert-


Hawgwild is offline   Reply With Quote
Old Nov 7, 2010, 11:47 AM   #14
Senior Member
 
rhermans's Avatar
 
Join Date: Jun 2005
Location: Antwerp - Belgium
Posts: 3,454
Default

Guys I don't wanted to say that shaking the sensor doesn't help, but it only helps and is not always a solution.
__________________
rhermans is offline   Reply With Quote
Old Nov 9, 2010, 8:20 AM   #15
Junior Member
 
Join Date: Nov 2010
Posts: 2
Default

Thanks for all the information and advice. I got a blower. It took a few tries, but it cleared it up.
ctdkite is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:46 PM.