Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Sep 3, 2011, 5:33 PM   #1
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default Already a weird problem with k5

After shooting in live view for a while today my camera froze in some kind of loop, making strange noises. Not mirror flops just whining sounds. The only way out was to remove the battery. This only has happened once. Still using 1.01 firmware. The camera is only 3 days old! I will upgrade to the newest firmware, but if this proves to be a problem, then I'm done with Pentax. Is this something found in the old firmware? My manufacturing date is May 19 2011.
tony3dd is offline   Reply With Quote
Sponsored Links
Old Sep 3, 2011, 5:59 PM   #2
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day Tony

-IF- the camera is less than a week old [as far as you are concerned] ...
1- try to repeat the noises, and if you can
2- take the damn thing back to the shop and get a DOA replacement

Regards, Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Sep 3, 2011, 6:40 PM   #3
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default

I have also noticed that at least in less than ideal light focusing in liveview is very inaccurate half the time. I guess this is what people are talking about when they compare Pentax to Nikon.
tony3dd is offline   Reply With Quote
Old Sep 3, 2011, 8:04 PM   #4
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default

Quote:
Originally Posted by Ozzie_Traveller View Post
G'day Tony

-IF- the camera is less than a week old [as far as you are concerned] ...
1- try to repeat the noises, and if you can
2- take the damn thing back to the shop and get a DOA replacement

Regards, Phil
Ok, I have worked the Liveview to death after upgrading the firmware to 1.11 from1.01. Could not duplicate the problem, plus the focusing in liveview improved a whole lot. Maybe there is nothing really wrong. I'll check it out more, but I feel the firmware may have been an issue. I read on Penatx's site that they improved autofocus in low light. Hence the much better focus. I've shot 82 liveview images with no freezing.

Last edited by tony3dd; Sep 3, 2011 at 8:08 PM.
tony3dd is offline   Reply With Quote
Old Sep 3, 2011, 10:21 PM   #5
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,056
Default

Upgrading the firmware to 1.03 made a huge difference for my first camera, not surprised you noticed a difference.

As far as your live view problem - I'm sure you are aware that the amount of time you can use live view or video isn't infinite. If it's hot out, your time will be less before the camera will overheat. I don't use live view all that much (I do use it occasionally) and when I do, it's usually only for a short time.

I once had my the SR on my K20 go haywire, buzzing and vibrating like crazy, when the camera was only a couple of months old. I turned the camera off and back on and it never did it again. Thought it was very strange, but it never happened again. It's entirely possible it was some one-off type of thing like that, without there being something actually wrong with the camera.

Good luck with it.
mtngal is offline   Reply With Quote
Old Sep 3, 2011, 11:29 PM   #6
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default

It seem ok for now. Never happened again. It's a shame really because the camera is perfect otherwise. Mine actually was stuck in some kind of loop. I had to remove the battery to stop it.

Last edited by tony3dd; Sep 3, 2011 at 11:32 PM.
tony3dd is offline   Reply With Quote
Old Sep 4, 2011, 10:44 AM   #7
Senior Member
 
Frogfish's Avatar
 
Join Date: Feb 2006
Location: Shanghai, China
Posts: 2,774
Default

We should remember that the CPUs in cameras are just smaller versions of those used in computers - and we all know how temperamental they can be. Often a quick reboot (i.e. removing and reinserting the battery) is all the camera needs to cure a 'problem'.

BTW this isn't just a Pentax thing Tony - spend any time at all looking at Nikon / Canon forums and you'll see umpteen problems there too.

Cameras are complicated pieces of technology that often, like any other complicated piece of technology, have their 'bad hair' days. No reason to give up on them at the first sign of a hiccup. Send it back / exchange it / find a fix / whatever, there are many cases of owners doing just that and then going on to greatly enjoy the replacement K5 without any problems at all.
__________________
http://frogfish.smugmug.com
Pentax : 15 Ltd, 77 Ltd, 43/1.9 Ltd, Cosina 55/1.2, DA*300/4, Contax Zeiss Distagon 28/2.8, Raynox 150/250, AFA x1.7, Metz 50 af1.

Nikon : D800, D600, Sigma 500/4.5, Sigma 120-300/2.8, Zeiss Distagon ZF2 - 21/2.8, Zeiss Distagon ZF2 - 35/2.0, Nikkor 85/1.8G, Sigma 50/1.4. Nikon x1.4 TC, Sigma x2.0 TC
Frogfish is offline   Reply With Quote
Old Sep 4, 2011, 1:41 PM   #8
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default

Here are some quick shots I took today using liveview. Auto focus seems right on now, and out of about 65 shots 63 were spot on in this horrible overcast day. Never had another freeze.














Last edited by tony3dd; Sep 4, 2011 at 1:44 PM.
tony3dd is offline   Reply With Quote
Old Sep 4, 2011, 4:45 PM   #9
Senior Member
 
mtngal's Avatar
 
Join Date: Nov 2005
Location: Frazier Park, CA
Posts: 16,056
Default

Pictures look really good! Record player is very cool, and I like the last one, an interesting building.
mtngal is offline   Reply With Quote
Old Sep 4, 2011, 5:18 PM   #10
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default

Quote:
Originally Posted by mtngal View Post
Pictures look really good! Record player is very cool, and I like the last one, an interesting building.
Thanks. The last one use to be a theater. It's closed now. I'm really impressed with the K5's noise, and dynamic range. Lots of detail in that tree in the last shot. The day was horribly overcast!
tony3dd is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:49 AM.