Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old Feb 12, 2013, 8:56 AM   #1
Senior Member
 
Join Date: Nov 2009
Posts: 589
Default 1.14 Firmware?

I'm still on firmware 1.12 on my K5. Should I upgrade to 1.14 or leave it? Thanks.
tony3dd is offline   Reply With Quote
Sponsored Links
Old Feb 12, 2013, 1:57 PM   #2
Senior Member
 
Catbells's Avatar
 
Join Date: Nov 2004
Posts: 874
Default

If you're not experiencing any issues as detailed in the updates then logic would suggest leaving things well alone.

However, it's also quite common for unpublished improvements to get included.

I've just updated to 1.14 from 1.13 to see if it improves issues that I have with AE-L (see thread: http://forums.steves-digicams.com/pe...e-v1-14-a.html) & have to say that I'm not too happy about the way it handles.

In Av Mode, viewfinder might show 1/125S @ f9
Press shutter half way & exposure changes to 1/400S @ f5.6
Release shutter & exposure shows 1/125S @ f5.6
Press shutter to take shot
Preview image shows exposure of 1/400S @ f5.6

Press AE-L & viewfinder STILL shows 1/125S @ f9
Press shutter half way & exposure changes to 1/400S @ f5.6
Release shutter & exposure shows 1/125S @ f5.6
Press shutter to take shot
Preview image shows exposure of 1/400S @ f5.6
IMHO, AE-L has not locked the exposure!

In Tav Mode, viewfinder might show 1/30 @ f9 with ISO @ 2500
Press shutter half way & ISO changes to 800
Press shutter to take shot
Preview image shows exposure of 1/30 @ f9 with ISO 800

Press AE-L & viewfinder STILL shows 1/30 @ f9 with ISO @ 2500
Press shutter half way & ISO remains at 2500
Press shutter to take shot
Preview image shows exposure of 1/30 @ f9 with ISO 2500
AE-L has locked the exposure

Unfortunately, there's no way back!

UPDATE: I should just add that under the Custom Menu, Link AE to AF Point was set ON. Setting this to OFF 'resolves' the above Av Mode situation. The scenario I was using had a bright centre & the surrounding area was dimly lit. Focus was set to centre & it would appear that when the shutter was pressed half way, focus was locked & the exposure was taken from the SPOT position in the bright area thus changing the exposure. However, my contention is that if you set AE-L to lock the exposure it should be at the settings when AE-L was set & should not change as press the shutter half way. After all, this is exactly what happens in Tav Mode!! So Pentax have inconsistency in the way that the K5 handles AE-L!!
__________________
Pentax K10/K5, DA18-55mm, DA50-200mm & Tamrom 18-250mm

Last edited by Catbells; Feb 14, 2013 at 1:00 PM.
Catbells is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:06 AM.