Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Pentax / Samsung dSLR, K Mount Mirrorless

Reply
 
Thread Tools Search this Thread
Old May 12, 2013, 4:45 PM   #11
Senior Member
 
Join Date: Nov 2004
Location: Mount Shasta, California
Posts: 1,525
Default

After seven cleanings, got it down to one small spot, only seen at 100 percent and only against a clear blue sky. It will do. Thanks for your help.
pboerger is offline   Reply With Quote
Old May 12, 2013, 5:28 PM   #12
Senior Member
 
bluenose's Avatar
 
Join Date: Mar 2009
Location: Ontario, Canada
Posts: 470
Default

Glad you have fixed the issue. I am curious as to what cleaning product/system you used as at some future date I'm sure I will need to do a sensor cleaning and whatever you used worked wonders.

Regards
bluenose is offline   Reply With Quote
Old May 12, 2013, 9:37 PM   #13
Senior Member
 
Join Date: Nov 2004
Location: Mount Shasta, California
Posts: 1,525
Default

It's against the rules, but I used isopropyl alcohol and cotton swabs. There are systems out there that claim to do better.
pboerger is offline   Reply With Quote
Old May 12, 2013, 9:48 PM   #14
Senior Member
 
VTphotog's Avatar
 
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,214
Default

I use VCR cleaning swabs which have a chamois end, with 100% isopropyl alcohol, after a thorough going over with a blower. It has taken several passes on occasion.

brian
VTphotog is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:09 PM.